FvwmTaskBar for multi desktop displays

I’m trying to configure a task bar for .fvwm2rc and have two problems. Both are illustrated by thescreenshot posted here:


          1)   I have a 3x3 desktop but the buttons that are displayed in the FvwmTaskbar display only show the xterms that are open on the desktop that has the focus.     I'd like to display all open xterms.     is it possible to do that and if so how?
           2)   The titles in the Taskbar are of the form XTerm:<Title>.       Presumably    The XTerm: is there because fvwm can't find the appropriate icon.    But I want to eliminate anything but the actual title of the xterm.  I.e., I want the Taskbar buttons to say "Alex", Lindsey, Rachael, etc

How can I do that?

Here’s a stripped down version of my .fvwm2rc file

Thanks for any advice

[code]DeskTopSize 3x3
Style FvwmPager !Title
Style FvwmPager FixedSize
Style FvwmPager HandleWidth 1
Style FvwmPager Sticky
Style FvwmPager WindowListSkip
Style FvwmPager StaysOnTop
Style FvwmPager FixedPosition
DestroyModuleConfig FvwmPager: *
PipeRead ‘echo *FvwmPager: Geometry $(($[vp.width]/5))x$[infostore.fvwm_pager_height]+$(($[vp.width]/2-($[vp.width]/5)/2))+0’
*FvwmPager: Colorset * 10
*FvwmPager: HilightColorset * 11
*FvwmPager: BalloonColorset * 16
*FvwmPager: WindowColorsets 14 15
*FvwmPager: Balloons All
*FvwmPager: SmallFont none
*FvwmPager: Font none
*FvwmPager: BalloonFont “xft:$[infostore.used_font]:pixelsize=$[infostore.fontsize]”
*FvwmPager: BallonYOffset +2
*FvwmPager: WindowBorderWidth 1
*FvwmPager: WindowLabelFormat “”
*FvwmPager: MiniIcons
*FvwmPager: UseSkipList
*FvwmPager: Rows 1
*FvwmPager: SolidSeparators

  • I Module FvwmPager
    Colorset 15 fg #ffffff, bg #003c3c, hi #005c5c, sh #001c1c
    DestroyModuleConfig FvwmTaskBar: *
    PipeRead ‘echo *FvwmTaskbar: 1 ButtonGeometry $(($[vp.width]/10))x0’
    PipeRead ‘echo *FvwmTaskbar: 1 ManagerGeometry 0x1+$(($[infostore.fontsize]/2))+0’
    *FvwmTaskBar: Colorset 15
    *FvwmTaskBar: Frame 0
    *FvwmTaskBar: Rows 1
    *FvwmTaskBar: Columns 1200
    *FvwmTaskBar: Action Click1 DeiconifyFocusAndRaise
    *FvwmTaskBar: Action Click2 Iconify
    *FvwmTaskBar: Action Click3 Menu Window-Ops3 c+0 -101m
    Module FvwmIconMan FvwmTaskBar

Check the Resolution configuration option for FvwmIconMan in the manpage

Resolution      global/desk/page/screen    page

By default the Resolution is to only show the windows on the current page. You can set the resolution to desk (for current desktop) or global (for all windows).

Thanks for this, @somiaj, setting Resolution to global was indeed what I needed.

Could you also please explain how I might resolve my other problem, which is how to control the content of what goes into the buttons.

My question has two, related parts.
1) All of my buttons consists of two parts, e.g., Chromium-browser: FVWM Forums . There’s a little box to the left of the text.
Presumably, this little box should have a Chromium icon in it instead of saying “Chromium-browser:”, but can’t find the right Icon. Similarly, the button for a Gnome-terminal says “Gnome-terminal: etc” with no icon.

My path for icons is I think standard, i.e.,

ImagePath /usr/share/icons:/usr/share/icons/wm-icons:+
ImagePath +:/usr/share/pixmaps:/usr/share/pixmaps/fvwm

but evidently this is not good enough. Could you explain how I might go about replacing the words with icons? Presumably I have to know exactly what icon, say, the Chromium-browser window is looking for

2) Most of my open windows are xterms.  The buttons for these windows all look like [code]

[/code] but I want them to just look like <xterm title> to save space. Again, I presume that the button says Xterm: because it’s looking for an icon that it can’t find. Even if I could replace Xterm: with the xterm icon, I’d still want to suppress the the icon.

Thanks very much for your help.

You should read through the list of options for FvwmIconMan in the manpage, they will help out a lot.

The options you seem to be looking for are

[code] Name Description Default

DrawIcons use mini icons false
Format describes button label “%c: %i”[/code]

The first defaults to false and thus you won’t see any MiniIcons. Make that true to see MiniIcons.

The second describes the format of the button label, and the default is class: iconname. Change the format to what you want.

Thanks! That worked.