gaim guifications

Hey all,

I have gaim 1.4.0-r2, guifications 2.10, and fv 2.5.12.

I’m having a problem with Fv switching to the desktop/page that the im window resides whenever a notification posts. Any ideas on how to fix this?


I want to know how to make the guification ignore the working area, I tried:

Style gaim* StartsOnPage 2 2, EWMHIgnoreStrutHints, \ EWMHPlacementIgnoreWorkingArea, \ EWMHPlacementIgnoreWorkingArea, \ EWMHMaximizeIgnoreWorkingArea, \ EWMHPlacementUseDynamicWorkingArea

but nothing happens with the notification area, I have:

EwmhBaseStruts 0 200 17 65

I got from xwininfo :

[code]xwininfo: Window id: 0x1e028d1 “gaim”

Root window id: 0xa0 (the root window) (has no name)
Parent window id: 0xa0 (the root window) (has no name)
2 children:
0x1e028d4 (has no name): () 191x44+0+0 +1209+17
0x1e028d2 (has no name): () 1x1±1±1 +1208+16

Absolute upper-left X: 1209
Absolute upper-left Y: 17
Relative upper-left X: 1209
Relative upper-left Y: 17
Width: 191
Height: 44
Depth: 24
Visual Class: TrueColor
Border width: 0
Class: InputOutput
Colormap: 0x20 (installed) Map State: IsViewable
Override Redirect State: yes
Corners: +1209+17 -200+17 -200-1139 +1209-1139
-geometry 191x44+1209+17

Bit gravity: NorthWestGravity
Window gravity: NorthWestGravity
Backing-store hint: NotUseful
Backing-planes to be preserved: 0xffffffff
Backing pixel: 0
Save-unders: Yes

Someone wants these events:
Do not propagate these events:
Override redirection?: Yes

Window manager hints:
Client accepts input or input focus: Yes Program supplied minimum size: 191 by 44
Program supplied window gravity: NorthWestGravity
No zoom window size hints defined

Window shape extents: 191x44+0+0
No border shape defined

Initial state is Normal State

Normal window size hints:
Program supplied location: 0, 0

Bit Gravity State: NorthWestGravity
Window Gravity State: NorthWestGravity
Backing Store State: NotUseful
Save Under State: yes[/code]

Style gaim*             StartsOnPage 2 2, SkipMapping

Should do the trick I suppose :slight_smile:

so in talking to theBlackDragon in irc…we got down to the bottom of the issue.

Turns out I had the ‘Message Notification’ plugin enabled. God knows what I thought that was or what it did…but it was the culprit.

The dragon’s suggestion for SkipMapping and startsOnDesk/Page will also come in handy with gaim…but that’s a different issue.

I don’t know if that helped you Danes…