gkrellm doesn't work properly


I use gkrellm 2.2.5 with

 *FvwmButtons: (20x50, Swallow "gkrellm2" `Exec exec gkrellm`)

to swallow gkrellm in a buttonbar, but gkrellm starts in a complete
different place. When I don’t swallow it, it’s the same thing it starts where it wants to start and ignores the -geometry option.
I also tested a few options from gkrellm itself and of corse I made it sticky…etc,
but nothing helped. I also can move it arround although it has no handles, shouldn’t get focus etc.


hmm, I don’t use gkrellm, but using the UseOld swallow option might convince FvwmButtons to swallow an already existing instance.

[EDIT]Ignore this, UseOld is not such a good idea at all it seems.

Gkrellm is well known for this. It’s very much like XMMS in that sense. Try using “NoClose” as a valid swallow option, and certainly don’t use “UseOld”.

– Thomas Adam

Thanks for your answers. I’ve tried both swallow options, nothing helped.
It seems that version 2.5.5 and 2.2.7 (I’ve also tested this one) don’t work with Fvwm 2.5.12. Sometimes I think it (Gkrellm) has a bug, because when I play with the option “show computername” (or whatever) it suddenly is in the right position.

Well I think I use torsmo or is there anything else out there ?

Call me old-fashioned (heh) but I use separate apps for all of this – xmem and xload are my favourites, but it depends on what you’re wanting to monitor.

If you want one of those “all in one” apps, procmeter3 (as I believe it is now called) is quite good. Or there’s xsysinfo or xosview…

– Thomas Adam

Oh! Oh! And xperfmon++!

Yes I know your old-fashioned config :wink: But your apps fit perfectly in this style.
xosview seems to be interesting.

I use torsmo AND GKrellM - while torsmo uses less resources & doesn’t clog up the pager, it doesn’t have all the functionality I want - like mounting flash drives. With a bit of jigging around with fonts & colors, I’ve managed to make it pretty hard to tell that there’s more than one app running at the side of the screen.

Incidentally, speaking of individual apps, I’d like to run analog xclock, but I can’t get the damn thing to change the bg color - I’ve tried every single option, it just doesn’t want to know. Anybody know what might cause this?

I’ve heard reports of a few bugs with certainly Xorg and xclock. It should be fixed soon, though. Just out of general interest though, have you tried also setting the background colour via ~/.Xdefaults:

xclock*background: some_colour

and then running:

xrdb -merge ~/.Xdefaults

Not that I’d expect it to work, if say, “-bg foo” to xclock doesn’t work; but you never know. :slight_smile:

– Thomas Adam

Yep, after command-line parameters didn’t work, I gave Xdefaults a go. It didn’t work either :frowning: