Green v2

I decided to abandon my previous config for a more minimal, visually-appealing, and easy-to-understand config. I’ve also dropped support for multiple color themes unless someone is kind enough to get a version working that uses transparency and colorsets.

The only requirements are imlib2, sudo (for shutdown/reboot), and a patched version of fvwm (thanks to frogb!). I don’t know what will happen if you try it without the patches. Presumably things will look crappy, but maybe not. The patches provide rounded corners, changing button pixmaps on hover, allowing multiple border pixmaps, etc.




nice cat !!! :smiley:
and nice’n clean config.


PS: thnaks for link to patches, they are great !

nice as usual stonecrest.

I need to patch fvwm so i can use transparency 8)

edit: those patches are awesome. Thanks for that link stonecrest

Wow!! These patches are exactly what I have been wanting!! Sweet - thanks stonecrest!!


Stonecrest , i’m looking for the same window’s decor as you but blue, maybe you’ve seen it when you did yours …


Heh, apparently not a lot of people venture outside this forum :stuck_out_tongue: There’s a topic about the patches here.

ryo-san, the easiest way to generate the blue version of this is to install xfwm-svn and choose a gtk theme, like clearlooks, that is blue (since the xfce window manager themes pick up your gtk colors). The default xfwm theme is essentially the one you see in my screenshot, although they have since dropped the red x button - but you can use the one i have. Then take screenshots of active and inactive windows. Between those screenshots and the pixmaps in my theme, it shouldn’t be very difficult to great a blue fvwm decoration just like this.

thx stonecrest.

Great work!
By now I’m compiling cvs but I took a look at the configs. Very clean code! :slight_smile:

Well done! I’m using your config and the patches works very well.
I get only one error starting X:

[FVWM][__execute_function]: <<ERROR>> Command can not be added to a decor; executing command now: 'ButtonState Hover true'

Do you know what appens?

Yup, I get this as well. I assume it can be safely ignored because the hovering is indeed working (i.e. you can see the pixmaps change when you hover over the maximize button) and I believe I have the syntax right. But you can mention it to frogb in his patches thread on the forum if you’re really interested. And thanks.

I wish you implemented a pager :slight_smile:

who do i have to $%^@$ to get gaim to stop taking focus?! :imp:


DestroyFunc UrgencyFunc


Heh – I’ve had this in #fvwm’s channel FAQ for yonks, and also mentioned it here on the forums several times.

They joys of this forum’s search feature should always be used.

– Thomas Adam

I’m having some trouble with the whole borders/handle thing I assume I need to reszie my NE/NW pixmaps but I’m not sure what exactly I am trying to achieve. Can you explain why you NE/NW pixmaps are the way that they are? What creates the border effect? The actual fvwm border, the N pixmap or the active pixmaps themselves? :confused:

OK - I figured it out! To hide the handles that still seem to show I needed to make the NE/NW/SE/SW pixmaps 27x27 - you also need all 8 multiborder pixmaps in place for multiborder to work - that was my main problem :slight_smile:

Anyone know how to protect a panel from the rounding? This doesn’t work:

!RoundedCornersTop, !SlightlyRoundedCorners
  1. Make the CornerImages larger then your titlebar. Higher and wider.

  2. !RoundedCorners

Does that work for you personally? Doesn’t seem to work for me.

Style "gnome-panel" EWMHIgnoreStrutHints, EWMHPlacementIgnoreWorkingArea, !RoundedCorners, NeverFocus

I am assuming that gnome-panel in this case inherently doesn’t have any FVWM decoration? In which case, a style option of !RoundedCorners (with the necessary patch) wouldn’t make any difference.

– Thomas Adam

Works for me on my FvwmButtons, FvwmPager and FvwmIconMan, so yes.

Style FvwmButtons !Title, !Handles, WindowListSkip, Sticky, !Borders, StaysOnBottom, !RoundedCorners

Thomas Adam you should say… it shouldn’t make a difference, it does however.