How can I run an extenal script

How can I run an extenal script?
I have the need t run a csh or perl script
all these lines do nothing:

Do {Exec sh -c "/nfs/iil/home/yoavk/Scripts/vnc/FvwmThemes/CshTestScript"}
Do {Exec /nfs/iil/home/yoavk/Scripts/vnc/FvwmThemes/CshTestScript}
Do "Exec  /nfs/iil/home/yoavk/Scripts/vnc/FvwmThemes/CshTestScript"

Yoav Koren

The second one ought to work. The sript is executable I presume? Also, have a look at ~/.xsession-errors if Fvwm logs to that file, it might tell more as to what exactly is wrong.

the second one doesnt work
did you succeed to do that? can you post such a line that works?
p.s I don’t have a file ~/.xsession-errors, where else can ir be?
thanks again
Yoav Koren

This one is from FvwmMpd:

Do {Exec mpc play } (GetValue 1) { >/dev/null}

I have found the solution

Set $Perl = {/usr/intel/bin/perl} Set $DIR = {/nfs/iil/home/yoavk/Scripts/vnc/FvwmThemes} Do {Exec }$Perl{ -w }$DIR{/PerlTestScript &}
you can look at [color=red]FvwmScript-ComExample[/color]
Yoav Koren