How to configure the icons to work with the menu

Hey all,
I’m new here and to fvwm and I thought I’d try it out because some of the screen shots look so nice. Okay my first question that I’ve been having trouble on is the icons. I set a folder with my icons in home/usr/.fvwm/icons but I’m not sure what to do to link it and even in the tutorials I can’t seem to get it to work. Is it that all I need to do is set the ImagePath to

ImagePath $[HOME]/.fvwm/icons:+

then in the create menu just mention the icon and then it will find the location like for example + %aterm.png%“Aterm” Exec exec aterm? Sorry if this is all jumbled up, I’m still trying to get this working. Thanks in advance for any help. :wink:


I think you just may be having a PATH problem.

Are you icons in YOUR actual home directory


or did you place them somewhere else.

Also if your aterm icon is in a subdirectory of “icons” directory, then you need to specifiy the subdirectory as well.

For instance. I have my image/icon files in several places…so in my config file I have my my image path set like this:

ImagePath ${HOME}/Icons:+:$HOME/.fvwm/images:+:/usr/share/icons

My Icons directory has several icons sets and each set is in its own folder so in my menu if I want to have an icon from the Graphite-Rade8 set it would be something like this:

+ "&Terminal%Graphite-Rade8/48x48/apps/konsole_red.png%"	Exec exec xterm

Fvwm knows to check my Image path and will stop at the first match of the icon. So in my case it looks first in Icons then .fvwm/images and then in /usr/share/icons/ etc…until it finds a match.

Hope this helps out

Thanks for the quick reply :slight_smile:

I have my icons placed in: home/scott/.fvwm/icons so that when I open my folder in rox, all the images are in this folder. So I should have everything set like:

ImagePath $HOME/.fvwm/icons:+

Then when setting up my menu use

  • %icons/aterm.png%“Aterm” Exec exec aterm

Will this work? Thanks again for your help.


That looks to me like it would look in .fvwm/icons/icons/aterm.png

You don’t need to specify anything other than the image name, so long as it’s in the right directory

Thanks guys!
That worked out and now I can see icons next to my menu. The weird thing is that they are huge but the important thing is I got them working and I plan on taking this a little step at a time anyways. On that note, does anyone know why the images which are normal size icons look so gigantic in the menu? Thanks again for helping me see the icons, it looks a lot better than just seeing a grey slab. :smiley: