How to disable iconified app titles and give maximized windows their own respective icons

I love my setup but there are a few things missing that make it look a slight bit weird.

First of all, iconified windows appear on the desktop as I’d like, but they have titles, which don’t look all that great.
I have tried EVERY solution possible.

Style Icon !Title, Style Icon NoTitle, everything I could ever think of, (obviously quite a few which completely break the config syntax   :upside_down_face:). However nothing works sadly.

On top of that, making the icons smaller would be pretty nice (if you know how to do that, include it in your response!)

Secondly, when windows are maximized, their buttons are messed up.

(left button is the maximize button, right is to iconify it)

And yes, I have tried EVERY solution possible like attempting to style other buttons than the ones I currently have.

With these two problems, I’m completely clueless.

If you know how to solve these problems, it would be highly appreciated!

Check the manual pages vs just guessing makes life easier. Every possible option should be there. If you look at man fvwm3styles (though this is in man fvwm2 as well under Styles) you will see two useful styles, IconTitle and !IconTitle.

Fvwm doesn’t really support resizing images (unless they are .svg images which are designed to be scalable). Icons are usually pixmaps, so to control the size you will have to build your own icons. Once you have created an icon image (i would use .png), then Style appname Icon imagename.png.

There are ways with using tools like convert to resize the icon to a smaller size then use that one with fvwm, that would require a little scripting with fvwm functions and a shell.

As for the buttons, take a look at the configuration. If this is only an issue when you maximze windows (but buttons look fine otherwise) then you have something setting a MwmDecorMax ButtonStyle to that button, which will change the button for maximized windows. You can either just not set this ButtonStyle, or update the Toggled ButtonStyle which is used for maximized windows. Check the default config for how it configures the ButtonStyles.

Due to me having a GTK icon theme, I couldn’t get the icon part to work, but I managed to fix the maximized buttons with a bit of digging so thank you for the help!

Unsure what you mean by GTK icon theme here, most applications that have an Icon define this internally and don’t use an icon theme. But if you want more control over the icons, you’ll have to track down and define icons for each and every app you use.