How to migrate from FVWM2 to FVWM3

I have fvwm3 compiled in a users home directory. I have my fvwm2 configuration file loaded.

But I am missing my user-created modules. Has this changed?

Also I would like to request that the man pages for fvwm3 be posted online. I don’t really want to install asciidoctor on my machine. Are the man pages hosted somewhere? Is there a write up of migrating fvwm2 config file to fvwm3?

Hi @Franky

We no longer host the man pages online, but you can build them yourself, but you will need asciidoctor or asciidoc.

I don’t consider that unreasonable.

As for notes on migration, see: Upgrading From FVWM2 to FVWM3 (and key features in FVWM3) · fvwmorg/fvwm3 · Discussion #878 · GitHub

That page doesn’t seem to explain why my modules are not working. I had read in another post that the configuration file from fvwm2 works fine it fvwm3. But it doesn’t, at least not in my configuration.

Without any available documentation, I really don’t want to install something like ‘asciidoctor’ just to find out my problem persists. I’ll wait a few more years before looking at switching. Hopefully it might go smoother.

As a side note, with github, it doesn’t cost you anything to display man pages for your package on there. Just out right refusing to do it, might be what’s holding back users from switching to fvwm3.

Just IMHO, I’m sure you guys know what you’re doing by removing the old documentation, and not posting new documentation. But damn, I can see a problem with it.

Thank god for the wayback machine. Wait, maybe you could post the new man pages, and add them to the wayback machine. Then you can delete them, like you want to. Just a thought.

In which case you’ll have to be much more specific and forthcoming with information so that I can assist you to get things working.

Can you post one of your modules here having a look at it? We may solve the problem or find out if something is missing in Fvwm3, besides missing documents.

I reduced my config file to one module and the problem still existed. Not wanting people to just say my config is bad, I decided to try fvwm3 with the default config to see how the code it come with, gets on. It doesn’t.

The default config loads to a blank screen. There is access to a menu with the left click of the mouse. When I select xterm, it loads xterm and never gives it focus. By mouseover or mouseclick, is never gets focus. Then clicking on FvwmConsole, under the menu, does absolutely nothing. I believe FvwmConsole is a module. One that’s included in the default config. And one that doesn’t work.

Are these initial problems just the current state of fvwm3 or is my system not setup right to run fvwm3?

There were no errors during the compiling. Also, there used to be an option under fvwm2 -D which created a log file. The option isn’t available in fvwm3 (not that I can find), and no errors are ever outputted. Is there an option for debugging fvwm3?


Hmm, that’s certainly not what should be happening.

The best thing to do is to start fvwm3 with logging enabled. You can do this with:

fvwm -v

Which will output to a log file in ~/.fvwm/fvwm3-output.log by default. If you can send me that, I should be able to determine what’s going on.

Not sure how to send it to you, so here you go.

[1711316782.718912] FScreenInit: Using RandR 1.6
[1711316782.739052] main: Loading window states via (null)
[1711316782.755019] CMD_Read: file ‘/usr/local/share/fvwm3/ConfigFvwmDefaults’ not found
[1711316782.755150] main: couldn’t find/load [0]: /home/me/.fvwm/config
[1711316782.755159] main: couldn’t find/load [1]: /usr/local/share/fvwm3/config
[1711316782.755168] main: couldn’t find/load [2]: /home/me/.fvwm/.fvwm2rc
[1711316782.755177] main: couldn’t find/load [3]: /home/me/.fvwm2rc
[1711316782.755186] main: couldn’t find/load [4]: /usr/local/share/fvwm3/.fvwm2rc
[1711316782.755195] main: couldn’t find/load [5]: /usr/local/share/fvwm3/system.fvwm2rc
[1711316782.755204] main: couldn’t find/load [6]: /usr/local/etc/system.fvwm2rc
[1711316782.755213] main: couldn’t find/load [7]: /usr/local/share/fvwm3/default-config/config
[1711316782.755219] main: Cannot read startup config file, tried:


How did you install fvwm3? I suspect you didn’t run “sudo make install”? Or did you set a different PREFIX?

Does the /usr/local/share/fvwm3 exist? Anything under it?

So no, I didn’t run the last command as I don’t have access to install to the system. I was under the impression that this could be run/tested from a user directory without installation.

Can fvwm3 only be run when fully installed on the system?


This is what the --prefix option to ./configure is for.

For example:

./configure --prefix="$HOME/whatever"

Will install fvwm3 relative to $HOME/whatever – which is probably what you want, or some other directory of your choice.

[1711425785.352123] FScreenInit: Using RandR 1.6
[1711425785.374107] main: Loading window states via (null)
[1711425785.389973] CMD_Read: file ‘/usr/local/share/fvwm3/ConfigFvwmDefaults’ not found
[1711425785.390131] main: couldn’t find/load [0]: /home/me/.fvwm/config
[1711425785.390140] main: couldn’t find/load [1]: /usr/local/share/fvwm3/config
[1711425785.390151] main: couldn’t find/load [2]: /home/me/.fvwm/.fvwm2rc
[1711425785.390165] main: couldn’t find/load [3]: /home/me/.fvwm2rc
[1711425785.390173] main: couldn’t find/load [4]: /usr/local/share/fvwm3/.fvwm2rc
[1711425785.390180] main: couldn’t find/load [5]: /usr/local/share/fvwm3/system.fvwm2rc
[1711425785.398401] main: couldn’t find/load [6]: /usr/local/etc/system.fvwm2rc
[1711425785.398425] main: couldn’t find/load [7]: /usr/local/share/fvwm3/default-config/config
[1711425785.398433] main: Cannot read startup config file, tried:
[1711425866.645941] setup_window_placement: Expanding screen from ‘null’ → ‘’
[1711425916.164080] do_execute_module: No such module ‘FvwmConsole’ in ModulePath ‘/usr/local/libexec/fvwm3/1.0.9’

Still the same problem as described before, where I can map an xterm window, but it never gets focus, either mouseover or mouseclick. Also fvwmConsole is not loading.

You’re either not loading the correct binary, or using the wrong one from $PATH, or didn’t actually run make install. Try this in your fvwm3 source tree:

make clean
./configure --prefix=/tmp/fvwm3-tmp
make install

That’ll put your fvwm3 installation under /tmp/fvwm3-tmp

Then you can:

cd /tmp/fvwm-tmp && bin/fvwm3

… which will start fvwm3. Note as well, we can verify where fvwm3 in this installation is looking for its files, relative to /tmp/fvwm3-tmp, by doing:

$ strings fvwm3 | grep -C10 ConfigFvwmDefaults
can't open display %sto get the default display
couldn't find default display (%s)
can't open display %s, single screen number %d maybe not correct
Screen %d is not a valid screen
Hummingbird Communications Ltd.
Network Computing Devices Inc.
ImagePath /tmp/fvwm3-tmp/share/fvwm3/default-config/images
SetEnv FVWM_DATADIR /tmp/fvwm3-tmp/share/fvwm3
+ I Read /tmp/fvwm3-tmp/share/fvwm3/default-config/config
+ "&2. FvwmConsole" Module FvwmConsole
Read /tmp/fvwm3-tmp/share/fvwm3/ConfigFvwmDefaults

It’s therefore looking in the correct place.

Ok, now I’m getting somewhere. It appears the problem was with my lack of experience compiling packages as well as the command make clean.

My error was thinking that running configure did a fresh configure.

Thanks for your patience!

1 Like

@Franky In response to the manual pages, you are not alone in wanting them online again as others are so use to everything being online, but the problem is online info gets out of date and must be maintained. The reason the man pages were removed is they were for an older version of fvwm 2 and hadn’t been updated in a long time. Not a big deal for fvwm 2, but with fvwm 3 starting to drift, we felt that having out dated man pages was undesirable.

As for adding new fvwm 3 manpages, this could be done (and we may in the future since users do request it), but the reality is no documentation is going to be more reliable than the one built with the version you are using, so really users would be better off using locally built man pages than a version online that may or may not be compatible with the version you happen to have installed.

@somiaj I get that we idiot proofed the world and now it’s full of idiots. But I was able to find a copy of fvwm3menus online, but it is from a fvwm3_1.0.6a+ds-1build1_amd64 build. I was able to see the package versions didn’t match.

The same thing COULD be done for other versions. But sadly isn’t. And with free hosting of info on the internet, it’s hard to understand why.

I’m coming from using arch linux and they had the same horrible philosophy. If doing something upstream helps many users downstream, then don’t do it. They make the downstream users repeat commands multiple times, so the higher ups have less to do.

I guess this is the way to world is going though, as I just noticed the new version of firefox uses the same hotkey for multiple options on the same menu. What?!? When did that programming standard change? It’s like programming has returned to the wild west and you’re free to do whatever you like, regardless of logic.

For now, I’ll just see how far I can get with the 1.0.6 pages I found on the ubuntu website.