How to show icon in tray without icon in panel?

I use fvwm over Linux Mint Mate 20. I use email program sylpheed. When I start it, the icons of program appear in stalonetray and in the panel. When I click on the icon in panel or in the tray, the opened window of the program is iconified in tray but the icon in panel is in the panel. When I start sylpheed in Linux Mint, the icon in panel is disappeared, which should be the case. How do I fix this problem?

I found discussion of this question here . But above solution: Style sylpheed StartIconic, !Icon does not work for sylpheed. In Linux Mint the sylpheed’ window is iconified to tray (icon in panel is disappeared) by clicking on the icon of program in tray. How solve this problem in fvwm?

You have various options. First FvwnIconMan is the name of the module showing the icons in the panel on the right, so you need to configure it to ignore said window. You can have it ignore the window using the WindowListSkip Style

Style sylpheed WindowListSkip

This will mean the window is also not present in the WindowList (alt-tab by default). If you still want the window in the WindowList, but not in FvwmIconMan, then you need to tell FvwmIconMan to ignore the window. Here you can go find the FvwmIconMan configuration in the config and add a ‘DontShow’ line to it, telling it to ignore said window

*FvwmIconMan: DontShow class=sylpheed

In both cases make sure the class is ‘sylpheed’ or adjust as needed. See FvwmIconMan for more info on configuring it.

Unfortunately both methods do not help. Nothing is changed. I will try to read man FvwmIconMan for more details.

I went through all the options of FvwmIconMan but no luck. Maybe the problem belongs to this program only? I have not got this problem before with any program, it appears for sylpheed, only.

Both methods should work (provided I understood you correctly, that you no longer want this window to show up in FvwmIconMan – the task bar like list in default panel). Could it be that you don’t have the class of the window correct, use FvwmIdent to make sure you have the class correct.

Thank you that you remind about Identify. It shows that the Class is Sylpheed with capital letter S! Now it works. Thank you again.