Keybindings no longer work on Dell keyboard but do work on Logitech K810 keyboard

I have a new Dell E5580 machine running fvwm 2.6.5. I run it both with a logitech K810 keyboard and with Dell’s regular keyboard. Without modification,in order to get the function keys to work on the K810, you have to press the Fn button as well as the function key.

To make the logitech function keys work like they would on a normal keyboard (i.e., without hitting the Fn key), you have to do quite a bit of stuff as described in

Suddenly, this morning none of my keybindings would work from the default keyboard (with one exception), but all work fine with the Logitech keyboard (after following the steps described in the above link). For example:

Key F10 A MS Maximize 100 100

doesn’t work. The binding that does still work as expected is

Key F5 W A RaiseLower

On the other hand, the dell keyboard has now adopted the default behavior of the Logitech keyboard (except for F5)! To make F10 maximize the window using the default keyboard you now have to type Fn F10. It’s as if the modifications defined in the url have interacted with the fvwm software somehow.

Here are the three programs that do the work described in the above url:

/etc/udev/rules.d/00-k810.rules: (I’ve tried removing this file but the problem persists)

DEVICE=`journalctl | grep Keyboard | cut -d"," -f2 | cut -c1-7` KBD_ID=`journalctl | grep Keyboard | cut -d" " -f16` KERNEL=="$DEVICE", SUBSYSTEM=="hidraw", ATTRS{address}=="$KBD_ID", \ RUN+="/home/simon/batch/ %p"

BLUE_KEYBOARD=journalctl | grep Keyboard | cut -d"," -f2 | cut -c1-7
if [ “$BLUE_KEYBOARD” = “” ] ; then

Close STDOUT file descriptor

exec 1<&-


exec 2<&-

Open STDOUT as $LOG_FILE file for read and write.

exec 1<>$LOG_FILE


exec 2>&1
if [ “$ACTION” = “add” ]; then
# configure k810 ($DEVPATH) at $DEVNAME.
/home/simon/batch/k810_conf -d $DEVNAME -f on

The k810_conf file is a binary, posted here][/url].