Keyboard mapping

I can log into my PC using either GNOME or FVWM. GNOME uses the UK keyboard, which is what I want. FVWM switches to what I believe is US mapping. Is there anything in FVWM configuration that can cause this?

If not, any ideas where I can start to look?

Hi @brilyant

Run setxkbmap gb from within Fvwm’s StartFunction

Thank you for that - just what I needed.
(I don’t suppose I shall ever discover why the computer didn’t need this for Ubuntu <= 20.04)

Ummm. I made the mistake of booting the pc into Windows. When I returned to sanity, i.e. fvwm, I was back in a US map. and the setxkbmap gb instruction is definitely in place.

Cured by stopping fvwm, logging into Gnome, logging out and going back into fvwm.

I stress that this is not a problem for me, since I don’t use Windows very often, and I do have a simple fix. But I do wonder why.

Hi @brilyant

Presumably then, this is because when GNOME runs, it’s loading gnome-settings-daemon or some other process which persists when you log out of GNOME and run FVWM. You’ll have to track down what that might be.