KeyRelease not being bound

Hi all:

I am trying to catch a key press ala:

Key F20 A A FuncFoo

But, the KeyRelease portion of the XEvent is not being ‘caught’ at the FVWM side of things, and is being passed on to my application that has focus… which is causing very bad things to happen…

anyone know how/why something like that could happen? I catch the key press, but not the key release using the above code??

  • Skender

This is quite a popular question on the Fvwm mailinglists, this might answer your question :slight_smile:

I do. It was tried before — and failed. Well, I mean it worked, but not successfully enough, such that it was useful. There’s just no reliable way you can possibly trap key release events with FVWM, given that you’d need a time-delay to do so. You also have several possible race-conditions inherent in doing so.

As far as your application is concerned, Skender, you’ll probably just have to use a function that has a series of Schedule commands that deschedules your keys when you’ve pressed them. Note also that you might also find the style option:


of interest to you.

– Thomas Adam