make doesn't work for fvwm

First of all: Hello to everyone (I’m new on the board)!

I’m trying to install fvwm-2.5.12.
runs nicely, giving me the following output:

With Asian bi-direct. text support? no: No fribidi-config found in PATH
With Gettext Native Lang support? yes (libc)
With GTK+ required for FvwmGtk? yes
With GDK image support in FvwmGtk? no: Failed on gdk-imlib, see config.log
With GNOME libs support in FvwmGtk? no: Can’t find working gnome-config
With Iconv support? yes (from C library)
With Mouse strokes (gestures)? no: Can’t find working libstroke
With PNG image support? yes
With ReadLine sup. in FvwmConsole? yes
With RPlay support in FvwmEvent? no: Can’t find working librplay
With Shaped window support? yes
With Shared memory for XImage? yes
With Session Management support? yes
With Xinerama multi-head support? yes
With Xft anti-alias font support? yes (version 1)
With XPM image support? yes
With Xrender image support? yes

make also seems to be working and terminates without aborting.

As soon as I try to do checkinstall (or make install) I get the
following error-messages:

/usr/bin/install -c -m 644 ./fvwm.1 /usr/local/man/man1/fvwm.1
/usr/bin/install: Aufruf von stat für »/usr/local/man/man1/fvwm.1«
nicht möglich: Zu viele Ebenen aus symbolischen Links
make[2]: *** [install-man1] Fehler 1
make[2]: Leaving directory /home/we/fvwm/fvwm-2.5.12/fvwm' make[1]: *** [install-am] Fehler 2 make[1]: Leaving directory /home/we/fvwm/fvwm-2.5.12/fvwm’
make: *** [install-recursive] Fehler 1

**** Installation failed. Aborting package creation.

My system-language is set to German, that’s why the messages are
the same. It says something about stat for … not possible because
of too many layers of symbolical links :confused:

I tried to install with and without the translucency patch, always
getting the same errors.

Can anyone help?


It looks like it’s failing on a required library “gdk-imlib” which doing a search on Google suggests that it is in a package called “python-gdk-imlib”.
I can only see references to the package belonging to Debian.Are you installing on Debian?

I have FVWM installed on Gentoo which is just a case of typing “emerge fvwm” which installs all required dependencies so im just guessing.


Yes, it’s debian woody here :slight_smile:
I’ll check for that package and post as soon as I know more!



Ok, I’ve got the packages gdk-imlib1 (1.9) and python-gdk-imlib (0.6.9) installed. I guess fvwm needs a newer version. But ist “GDK image support in FvwmGtk” really needed for fvwm to install? What is FvwmGtk anyway? I suppose it’s only needed if running fvwm under Gnome (not so here). All of this still doesn’t explain why ./configure and make seem to work, without
letting me install with “make install”.


python-gdk-imlib (0.6.9) is the newest stable version.

There is a beta version of python-gdk-imlib-1.2 (0.6.12-2) see here: … -imlib-1.2

You could try that instead.

FvwmGTK is explained here:

Doing a search on google gives me the answer that at the moment you cant install fvwm without support for gtk but you can run configure with a switch: --disable-gtktest --disable-imlibtest --without-gnome

personally i would just install the gtk libraries


i have some like the same problem, but i have all the things installed.

iam running ubuntu hoary

If the error message means “too many levels of sybolic links” (it is what google says) its means that the file /usr/local/man/man1/fvwm.1 is a symbolic links wich points either to itself, or to somewhere which points back to itself (recursion in links). All you have to do is delete (or rename to fvwm.1.old) the file fvwm.1.

this is what i get

$ make
/bin/sh: -c: line 0: syntax error near unexpected token `)'
/bin/sh: -c: line 0: `if test ! -f )].in; then  rm -f ./;  make ./;  else :; fi'
make: *** [)].in] Fout 2 << error

system language is dutch

edit: i dont know what the error was but i have fixed it i have used a clean source (some how the source wasnt clean) repatched and compiled it

once i had this issue - IIR I manually deleted some files and then got a newer version of checkinstall.