Nautilus Hijacks my desktop

Hi guys, full of dumb questions again; :slight_smile:

having found the need to browse to some smb shares on the wider intranet here at work I decided to fire up nautilus and see if I could indeed connect to server shares.

When I launched nautilus it hijacked all my desktops and planted its background and changed the behaviour of the left and right mouse clicks - not surprisingly to what nautilus wants - how do I keep it to one desktop only or perhaps to a single window?

[color=red]Edited by theBlackDragon:
–> moved from Basic questions[/color]

You can either start nautilus with the --no-desktop flag or you can add

Style desktop_window EWMHIgnoreWindowType, !Title, !Handles, !Borders, FixedPosition, UsePPosition, StickyAcrossPages

to your config, depending on if you want a desktop window or not.

Thank you! That works a treat.

can you run only the desktop_window of nautilus? it opens also the home directory, not?

The flag -n seems to do that.