nautilus icons gone awol

Hi guys again :confused:

I have fixed all my fvwm icon sets and things are starting to come together.

I have another icon prob that having googled seems to be relatively common but none of the solutions I read have worked for me:

linuxquestions.org/questions … p?t=245482
nautilus icons on fluxbox with a suggestion to:

and

linuxquestions.org/questions … p?t=280086

neither of these have worked for me - I still have the default blank page with corner turned down icon for all my nautilus icons (except where thumbnails are kicking in)
I am launching nautilus with exec nautilus --no-desktop and the standard icons are in my images path of config.

Any suggestions?Thanks as always :slight_smile:
Will

Wildly off-topic, hence moved to ‘‘other questions’’. Please be more precise with question placement in the future, William.

– Thomas Adam

This is probably the same problem reported here and can be solved by running /usr/libexec/gnome-settings-daemon.

Unless it turns out these topics are not related I’ll probably lock this one and move it to dups, I’ll give it some days first (and hope I don’t forget :wink: )

Thanks BlackDragon - this fixed the Nautilus problem. Something still wierd with the gnome-panel and I have ditched it anyway - so I can’t confirm that but I suspect that this is the solution. Many thanks.

Sorry about the duplicate - seems that I am really struggling around here :confused:

William

I’m not sure what you mean by that, but the icon directory should be in ~/.icons (or /usr/share/icons).

For example, I have ~/.icons/nuoveXT-1.6/index.theme and

gtk-icon-theme-name = "nuoveXT-1.6"

It’s pretty silly to run gnome-settings-daemon just for your GTK icon theme when it’s not needed, in my opinion.

Hmm, that would imply that your avery default GTK installation is broken then? I don’t really feel the need to have duplicates of system wide installed themes in my homedir just so GTK can find them…

Running gnome-settings-daemon is more of a convenience solution I use until I bump into a better one (I don’t feel like searching hours after something that ought to ‘just work’)

As a sidenote: seeing that this thread is not related to the one mentioned before it does not calssify as a dup and thus can stay around :slight_smile:

OK, so I am pointing at the icon directory that houses the GTK icons for Nautilus but I have not defined the “theme” as you suggest StoneCrest. (/usr/share/icons)

gtk-icon-theme-name = "nuoveXT-1.6"

is that an .Xdefaults entry? My gnome install got broken badly when I was screwing around with hot swapping wms from metacity to fvwm and I have abandoned gnome for the moment entirely.

The only thing I had to change when using the settings-daemon is that it starts xscreensaver for me and I had to remove that from the start function in fvwm config.

In fact I think if I can find a better fm than nautilus I will dump it - just not that familiar with rox or any alternatives - such is the sheltered gnome life I have lived :slight_smile:

No. It goes in your ~/.gtkrc-2.0 file.

– Thomas Adam