New and carrying a basic question

Hi guys, first of all I am new here and although not really new to Linux I am only just starting to learn some of the finer points of X and how to make a really optimised system.

I have recently switched to Gentoo and built a really fast and clean 2.6.16 kernel from the vanilla sources tree. I have always favoured Gnome as my primary WM/Env but have recently started doing lots of Win VM work and need a super lean and powerful WM to run behind the VMs for presentations and times when the clients and team really need to see the VM running as fast as I can…

Hence I immediately harked back to F(rugal?) which I have not used since it was a selectable option in the early days of red hat … I didn’t really understand the differences then and now I am keen to have FVWM and Gnome/Metacity as my p;rimary environments. The Gnome2.14/Metacity is working really well for my day to day familiary environment but I wouldn’t put it past FVWM to become my local hig performance wm.

But (it was always coming :slight_smile: ) I can’t work out how to start the thing.

I want to start from very basics - after all, all I really need to start with is a terminal to launch vmare on the laptop screen and go to full screen. At the moment I am selecting a custom session from gdm when I need to have a lean backend to my VMware session.

I have emerged fvwm and I have a large xorg.conf file designed for xinerama/mergedfb for metacity/gnome and an rc.conf file that specifies GDM and Gnome as my desktop managers and XSESSION.

I have no conf available in my .fvwm directory and looking at the fvwm directory in /usr/share/fvwm there are heaps of confs with descriptive names appended.

Reading the man I can see the order of confs that the wm will look for and yet whatever I do I get a message at the command line that I cant grok and google has not really helped.

# fvwm
[FVWM][main]: <<ERROR>> couldn't open the display

Sorry this is not exact message since I am at work and in Gnome with a VM going and can’t interrupt my session to see the error exactly again.

Any hints.

I have been following the Gentoo Howtoo and looked at several FVWM sites for some basic help but still come up confused.

I know it is basic and will continue to search but I thought I’d come to the source and make a fool ish noob of myself anyway - I hope this is not too preemptory a post. I am searching and researching :slight_smile:


Hello, and welcome.

Depends how you login to X11. I suspect you use some kind of graphical display manager, such as XDM or KDM or GDM. Now, in an ideal world, I’d like to say that they all read a known file in your home directory called ~/.xsession, alas it seems that KDM and GDM don’t, thus breaking most previously defined “standards” set by XDM and startx(1).

startx and XDM will read ~/.xsession – it’s an ordinary shell script if you like, hence it must have exec perms on it (chmod 700 ~/.xsession), and it might typically look like:


# Run the specified WM
exec fvwm

Now, XDM by default will read this file if it exists. If it doesn’t, then the global XSession file is read, which typically defaults to something boring. KDM ought to read this file, assuming one selects the “failsafe” option from the choices menu before one logs in. GDM too, although I understand this is no longer the case, in lieu of creating a .desktop entry for GDM to read — details on how to do this exist in these forums; search for “GDM”.

Note that the command “startx” (which is run from the command-line) also invokes X11 and reads ~/.xsession, but ONLY if ~/.xinitrc is not present. “~/.xinitrc” acts and performs the same purpose as ~/.xsession, except that ~/.xinitrc is specific to the startx(1) command only.

Of course, some systems have a mechanism of defining the WM of choice via a global environment variable. I know gentoo does this, but I do not know the specifics of how you change it, as I am a Debian person, although a reasonable guess would be something like:

WM="$(which fvwm)" startx

(assuming you wanted to start that from the command-line.) The non-distro specific mechanism is:

startx -- /usr/bin/fvwm :0

Oh, then you ought to be aware of the mechanics it’s using — see above,


When you invoke FVWM with no config, the root menu will invoke a FvwmForm that copies several files to ~/.fvwm for you which you can then edit to your heart’s content. Personally, I wouldn’t bother with that — and a persual of the configs posted to these forums might better suit your needs, or indeed you might prefer to try fvwm-themes

You should read the fvwmwiki

This suggests you’re trying to invoke FVWM as the user who has not started X11. Can you please detail step-by-step what it is you do to reach the stage such that you get that error?

Which sites, out of interest? (I keep a track and a log of FVWM sites — the ‘‘database’’ I since passed onto theBlackDragon for his website).

– Thomas Adam

Thomas, thank you very much for such a detailed and considerate reply.

I can point you only to the sites I have got from google that I looked at and the Gentoo Wiki:

I am working with my rc.conf file to see if I can get the fvwm2 script in /etc/X11/Sessions to start the WM properly.

I am finding it hard to report on my findings because I am in a Gnome X session with live VMs running.

I will cogitate on what you have provided and report back later today.

Many thanks


Awesome, I was able to start my fvwm session exactly as described - use fvwm2 as the xsession option in rc.conf - now I just have to work out a way of passing that to the X server more dynamically rather than editing rc.conf. I would use .xinitrc or .xsession if it helped but I would rather do it something like:

startx – [-wm [fvwm2]] -layout Xinerama

which I’m sure is possible - ie passing the desired xsession to xinit on startx along with an xorg.conf configuration…

Thanks again for the help - it was just enough to push me over the edge!@ :slight_smile:

I have tried to launch FVWM via startx as you recommend:

startx – /usr/bin/fvwm -layout Xinerama

and it complains about the format. invalid option :0

Anyway it has worked magnificently for running two independent VMs today - a Win2003 Server on one screen and an XP box with all the fruit on t’other and both performed tollerably - well enough to work with - although when I dem a system it will be only one at a time on this notebook.

I am stoked that my xorg.conf is working for my server layouts.


I have discovered that I can launch a second X with FVWM with

startx /usr/bin/fvwm – :1.0 -layout XineramaLayout

:slight_smile: loving it!