New Module: FvwmRingMenu - An Eyecandy Iconic Popup Menu

Hi All,

I’d like to present my latest module: FvwmRingMenu. If you’ve been reading the modules-from-scratch, you’ll know all about this. If not, you don’t need to know how to write it in order to use. What it does is allow you to create menus that look like this:

Most of those menus are launchers, some of them start sub menus:

Here’s my SSH menu

So I name my machines after horror films. What of it? :stuck_out_tongue:

The module is in this tarball. There’s a readme file to describe installation, and a man page in HTML format.

I’ll post some more ideas of how this thing can be used later in the week

[edit] typo

Last night ran late, and I ended up leaving out a few screenshots. To start
off, I’d hate for anyone to think that this only worked on dark brooding
config like those I seem to prefer.

For that matter, I’d hate you think they needed round icons:

That’s two minutes work to draw the star using inkscape - and most of that was spent trying to remember where they hid the stoke and fill dialogue. The icons 48x48-kde2, courtesy of the Window Manager Icon Project.

If you can cope with small icons, you can get a tight circle around the pointer

Icons from the same source, the 22x22-aqua set .

If you don’t have a huge number of apps, you can flatten out your menu entirely:

I quite like that. I think I’ll have to add an option to have icons auto-raise on mouseover events. It’d be nice to define a mouseover icon as well, maybe a clicked one too.

Of course, you can get carried away trying to fit everything in. The Harley Quinn wallpaper is by Doc_Jones of deviantart.

So, anyone want to help me test this sucker? It’s still very alpha, but it works on my machine. I’d appreciate any feedback.

[edit] typo

euhm, Nick, your manpage gives me a 404…

D’oh! Uploaded to one server and linked to another…

It should work now


I’ve got to stop drooling on my keyboard, otherwise it’ll short-circuit…

First bug found: didn’t work without a setting image. Now fixed.

props to mirko_3 on the gentoo forum for the report.

new tarball here

I would like to know what are the advantages and also a full screenshot of it in action !

You click on a button and an application starts. Just like normal list menus, except these are prettier.

Some people also reckon it’s a more efficient way to select an option, and that the mouse doesn’t have so far to travel. I think that part of it is largely a matter of taste.

I’m planning on adding some bells and whistles in due course. Up until then, these are as “in action” as it gets.

“click on a button and an application starts”. Not “icon”. :unamused:

Im haveing a problem. Everything works great execpt it will only show one icon. I dont get any errors about being about to find them. For every button it only shows my menu_setting.png and thats in the same directory as the others. Other than that it works great. Im able to access all sub menus and it launches apps just fine. Heres my config

        DestroyModuleConfig FvwmRingMenu: *
        KillModule FvwmRingMenu
        KillModule FvwmButtons FvwmRingMenu-FvwmButtons-*

        *FvwmRingMenu:  Debug           0
        *FvwmRingMenu:  IconSize        50
        *FvwmRingMenu:  Offset          -22,-22
        *FvwmRingMenu:  Radius          60
        *FvwmRingMenu:  Setting RingMenu/menu_setting.png Geometry +0-2
        *FvwmRingMenu:  OriginPolicy            Pointer

        # top level menu
        *FvwmRingMenu:  Menu TopLevel, Icon $[fvwm_icons]RingMenu/l33t_TER_term.png,          \
                        Mouse1 "FvwmEterm"                            \
                        Mouse3 "Module FvwmConsole"
        *FvwmRingMenu:  Menu TopLevel,                                  \
                        Icon $[fvwm_icons]RingMenu/l33t_GAM_frozen-bubble.png,\
                        Mouse1 "*SubMenu Gaming"

        # Games
        *FvwmRingMenu:  Menu Gaming,                                    \
                Center  $[fvwm_icons]RingMenu/l33t_GAM_frozen-bubble.png, \
                        Mouse0 "*SubMenu TopLevel"

This is just my “test” config while I mess around with it.

One thing it might be is if the setting icon is smaller than one of the icons.

If that happens, the composition doesn’t happen, and the icon displayed is just the background icon.

I need to put a message in about that…

That was the problem. Is there anyway to close it other than pushing an icon?

It doesn’t catch any keystrokes, so escape doesn;t work… You could bind SentToModule command to a keystroke and send *Withdraw which ought to work

Hmmm that doesnt seem to work. Heres what i have

Key F3 A M SentToModule FvwmRingMenu *Withdraw

And it tells me theres no such cammand as SentToModule. Then i tried SendToModule and i get

Unhandled Message Recieved *Withdraw

Any Ideas?

my mistake, twice over. SendToModule is correct, and you can’t get to the star commands like that.

It’s an easy enough fix. I’ll sort it out this evening.

Hey nick, have you dropped this project?

He’s most likely busy with real-life. It happens. But then, as they say, patience is a virtue…

– Thomas Adam

Real life? Ahhh, not that again… :stuck_out_tongue:

Alas, it happens :slight_smile:

Seriously, since I last posted anything of substance I’ve managed to start a new job and a degree course, break my right wrist, and I’m just climbing down from the mad rush to catch up the time I lost through injury.

Typical really; nothing for ages, then everything happens at once.

I’ll see if I can’t get some work in on this over the weekend. It’s way past time I did some maintenance work

I’ve got to stop drooling on my keyboard, otherwise it’ll short-circuit :slight_smile: