No sound in FVWM

I have installed Ubuntu and when I use gnome the sound works fine. But when I start fvwm instead the sound in rgythmbox does not work. I works fine when I use konqueror in fvwm (sound works when getting error messages etc.).

Why does the sound work in gnome when it does not work in FVWM?

[color=red]Edited by theBlackDragon:
–> Not an Fvwm problem, moving from Basic questions[/color]

you probably need the GNOME sound daemon running, start up esd or artsd or so.

That did it! I have now added:

AddToFunc StartFunction
+ I Module FvwmIconMan
+ I Exec exec esd

But each time I start FVWM it makes an annoying sound, is it possible to disable this startup sound that esd makes?

you’d need to look at the esd settings, i don’t use it so i have no idea…

Rhythmbox is a gnome program, so it’s programmed to get it’s sound device information through gnomes sound server, which is esd. a player like xmms gets the information directly from the driver, and does not require a sound server.

Though it is best to have all programs use a sound server if you use one as otherwise they might block eachother out of the use of the soundcard (which is what seems to happen with you).

Xmms is quite capable of using both Esound and Artsd to play music, though I’d personally recommend dumping xmms as one’s main music player :slight_smile: