NsCDE blinking vim document - xterm

Hi to you all;-), first time around on this forum.
I have an issue with NsCDE.
My setup is a little different from most for I’m running my FVWM setup from ISO, only!
This should of course not lead to the problem/s I have…
I have run FVWM default and with myExt from rasat without problems, from ISO.
So, now I have setup NsCDE, but when I open ‘xterm’ and a document with ‘vim’ I get a blinking document.
My setup is ArchLinux ISO with a complete X env. running FVWM with NsCDE.
It might be I forgot something but I can’t remember setting anything different and myExt theme, which is on the same ISO doesn’t have this issue.
Thanks for reading, hope I get this sorted.
Mark

Hi @qinohe

So you’re problem is running vim inside XTerm leads to a “blinking document”? Can you be more specific about what you mean?

Thomas

Hi @thomasadam thanks for your reply. I’ll try and be more specific.
I run an xterm terminal, in that terminal I open a document with vim.
If I open the document inside uxterm with vim everything is correctly displayed.
If I do the same with xterm, my color scheme is ignored and the whole document blinks like a ‘blinking-cursor’ on and off etc. This only happens using NsCDE.

Ah, OK. Probably a TERM issue then, or something exported/not exported in the environment. Hard to see how this could be a specific FVWM issue per-se.

If you open up uxterm and type echo $TERM followed by printenv what does that output?

Thomas

Sure, yes I thought about that too but couldn’t find any evidence…
Here are echo $TERM & printenv from uxterm

xterm

SHELL=/usr/bin/zsh
FVWM_SCRIPTDIR=/usr/lib/NsCDE/scripts
FVWMMFL_SOCKET=/home/binty/.NsCDE/tmp/fvwm_mfl.sock
XDG_MENU_PREFIX=nscde-
NSCDE_FONT_DPI=96
NSCDE_TOOLSDIR=/usr/lib/NsCDE
SDL_VIDEO_X11_DGAMOUSE=0
DPI=96
NSCDE_ROOT=/usr
SM_SAVE_DIR=/home/binty/.NsCDE/tmp
NSCDE_VERSION=2.0
XDG_CONFIG_HOME=/home/binty/.config
COMP_POINT=0
FVWM_OPTS=
NSCDE_PALETTE=Sand
EDITOR=vim
GTK_MODULES=canberra-gtk-module:canberra-gtk-module
XDG_SEAT=seat0
PWD=/home/binty
NSCDE_FVWM_VERSION_NUM=1.0.5
LOGNAME=binty
QT_QPA_PLATFORMTHEME=qt5ct
XDG_SESSION_TYPE=tty
HOSTDISPLAY=arial:1
FVWM_MODULEDIR=/usr/lib/fvwm3/1.0.5
FVWM3_LOGFILE=/home/binty/.NsCDE/tmp/fvwm.log
WINDOWPATH=1
NSCDE_PALETTE_NCOLORS=8
MOTD_SHOWN=pam
HOME=/home/binty
NSCDE_DPI=96
LANG=en_US.UTF-8
NSCDE_DATADIR=/usr/share/NsCDE
FVWM_FORMDIR=/usr/lib/NsCDE/forms
XDG_CACHE_HOME=/home/binty/.cache
FVWM_IS_FVWM3=1
XDG_SESSION_CLASS=user
TERM=xterm
GTK_OVERLAY_SCROLLING=0
USER=binty
FVWM_USERDIR=/home/binty/.NsCDE
NSCDE_OS=Linux
VISUAL=vim
SUDO_ASKPASS=/home/binty/bin/dpass
DISPLAY=:1
SHLVL=4
XDG_VTNR=1
XDG_SESSION_ID=1
XAPPLRESDIR=/home/binty/.NsCDE/app-defaults
XDG_RUNTIME_DIR=/run/user/1000
NSCDE_FVWM_VERSION_INFO=1.0.4-118-g44e21c5b
NSCDE_LIBDIR=/usr/lib/NsCDE
COMP_TYPE=0
XDG_DATA_DIRS=/usr/share/:/usr/local/share/
PATH=/home/binty/bin:/usr/local/sbin:/usr/local/bin:/usr/bin:/usr/lib/jvm/default/bin:/usr/bin/site_perl:/usr/bin/vendor_perl:/usr/bin/core_perl
FVWM_DATADIR=/usr/share/NsCDE/fvwm
DBUS_SESSION_BUS_ADDRESS=unix:path=/run/user/1000/bus
MAIL=/var/spool/mail/binty
CHROOT=/home/binty/chroot
COMP_KEY=0
A__z=F*COMP_KEY=F*COMP_POINT=F*COMP_TYPE="*SHLVL
OLDPWD=/home/binty
WINDOWID=35651596
XTERM_VERSION=XTerm(370)
XTERM_LOCALE=en_US.UTF-8
XTERM_SHELL=/usr/bin/zsh

edit: I don’t blame FVWM, I have a feeling (I know that’s no hard evidence) NsCDE has a setting that makes it be in this condition. I haven’t found it, yet. I will look further of course…

Hi qinohe, welcome to Fvwm forum.
From my test with NsCDE and myExt, it works fine besides a few changes. If the FrontPanel at the bottom does not appear, do edit .fvwm/config. Deactivate (tag) the below two lines.

Read $[myEXT_USERDIR]/1Functions/FVWM-Default/FVWM-StartFunction.sys
Read $[myEXT_USERDIR]/2-3Styles/FVWM-Default/FVWM-Page.sys

The first-line blocks FrontPanel, and the second line makes it jump from its bottom position after Restart NsCDE.

Hi @rasat thanks for your reply & warm welcome.
I’m not at the point where I can combine myExt & NsCDE.
They both run independently ATM and both run fine.
Both themes are on the same ISO both using all the same environment configs.
MyExt has no problems, but when using NsCDE I get the problem I described above^^
I think I should first find the setting that does this and do somehow agree with thomasadam, but, until now I’m unable to track it down.
When I’m done doing this I can have a look at bringing MyExt & NsCDE together;-)

Mark

This seems to me an issue with NsCDE and the way it “themes” xterm.
You can have a chat with Hegel in the irc channel or report the issue here: Issues · NsCDE/NsCDE · GitHub

Thanks, yes I think it’s a setting in NsCDE.
I removed all configs related to env. like ‘gtk-configs, Xresources’ and all local VIM config’s but it didn’t work. I used myExt also a spin-off, which works fine with all configs available and removed.

I tried to find what does this and didn’t. It may be a good idea to open a ticket on GitHub…