patches from

Integrate in 2.5.18 patches from

  • yes i want, it would be great !!
  • no i don’t want, it’s enough with new features …

0 voters

Does it is possible to integrate in 2.5.18, patches from

These patches give:


This was posted by the author to the fvwm-workers mailing list weeks ago. I can only assume some of them might make it into the 2.6.X version. This is my own conjecture, and not an official stance, though.

Broekn in latest CVS.

I cleaned them against the latest cvs. I posted in some old thread on these forums, but I post a link now again:

Gentoo Overlay: … ay.tar.bz2
The patchset alone: … 101.tar.gz

The patches are not mine, the original ebuild for gentoo is not either. I just modified them the only few bits that were broken against the latest cvs.

EDIT, features are always wellcome, but, as Thomas Adam said, they are discussed in the workers list. I don’t know much about how the fvwm team merge patches in the official branch, but I suppose that only patches being really stable will have any possibility at all of getting merged.

Yes I noticed this, however parts of the patches 11 & 12 fail against today’s snapshot. It’s about the lines again…

If you are using gentoo make sure you delete the old fvwm-patches-20071010.tar.gz from distfiles and download it again. I did some black magic on it some days ago but did not change the file name (mostly to save myself the pain of modifying the ebuild).

I just emerged it again the cvs ebuild, and it synchronized ok, patched without errors and compiled perfectly.

If you are compiling by hand and you get errors with the snapshot from today and with the latest tarball of the patches then let me know and I will check deeper.

The latest patch (download it even if you already have it, it might not be the same even if it is dated the same): … 101.tar.gz

Thank you for your work 6thpink. 8)

Updated them, the translucency and thinresize patch broke again today or yesterday it seems. More info and download links for the patchset and the ebuilds on the gentoo forums, here: … ml#3888222

As always, no guarantee at all. :stuck_out_tongue:


Thank you 6thpink for all the work!
One question: Im looking for a Hover.patch which is working with fvwm-2.5.21. Ive tried out different Hover-Patches
without success. Is there a Version which is working?


There is a hover.patch on that patchset, and all of the patches, including that one, do apply ok against current cvs as far as I know. However, I only use a couple of them, and the hover ir not one of those. So I can’t confirm it it works on this patchset, if it is broken and in that case, if I broke it or it was broken when I decided to modify the patches for them to work on the latest cvs releases).

I dont even remember what that patch do.

The patches are not mine, I just “cleaned” (if you can say it that way hehehe) a bit so they will work on current cvs. So, I should take no credit at all for the work, the original patches are the ones that are pointed along this thread. I just took them from there and modified them a bit.

Is that hover.patch not working or it is just that you are getting rejects when you apply it onto the cvs trunk?

Hi 6thpink,
yes I know that you are “just cleaning up” frogb`s Patches :slight_smile:

And thats a very good job youre doing!

Today I tried out different Snapshots from the last ~ 2 weeks and finally the latest cvs-Source from today without succes.

Only this Hover.Patch rejects, all other I`m trying out are working well (Trans-Menu, RoundedCorners, Iconman and flat-seperators).

It´s no problem, I can live without this Patch, maybe it`s interesting for you to get response about errors.

Thank you for doing this work!

I’m only semi-following this, but can you please pastebin some errors somewhere as to why it rejects, please?

– Thomas Adam

Hi Thomas,

no problem:

patching file fvwm/events.c
Hunk #1 FAILED at 158.
Hunk #2 succeeded at 1688 (offset 15 lines).
Hunk #4 succeeded at 2574 (offset 38 lines).
1 out of 4 hunks FAILED -- saving rejects to file fvwm/events.c.rej
patching file fvwm/fvwm.h
Hunk #1 succeeded at 724 (offset 18 lines).
patching file fvwm/screen.h
Hunk #1 succeeded at 198 (offset -4 lines).
Hunk #3 succeeded at 513 (offset -4 lines).
patching file fvwm/builtins.c
patching file fvwm/borders.c
Hunk #6 succeeded at 3878 (offset -122 lines).
Hunk #7 succeeded at 4269 (offset 2 lines).
Hunk #8 succeeded at 4421 (offset -119 lines).
Hunk #9 succeeded at 4594 (offset 2 lines).
Hunk #10 succeeded at 4564 (offset -119 lines).
Hunk #11 succeeded at 4703 (offset 2 lines).
Hunk #12 succeeded at 5045 (offset -119 lines).
Hunk #13 succeeded at 5188 (offset 2 lines).
Hunk #14 succeeded at 5081 (offset -119 lines).

That`s the complete Output if I try to patch the Hover-Patch against fvwm-2.5.21.
And the same kind of errors if I try to patch the latest cvs from today.


I really can’t be bothered with FVWM support at the moment.

I wanted the output from the .rej files, not the output from what you posted.

– Thomas Adam

do you mean that?

1 out of 4 hunks FAILED -- saving rejects to file fvwm/events.c.rej

fvwm/events.c.rej gives me that:

*** 158,163 ****
  int last_event_type = 0;
  Window PressedW = None;
  fd_set init_fdset;
  /* ---------------------------- local functions ---------------------------- */
--- 158,164 ----
  int last_event_type = 0;
  Window PressedW = None;
+ Window HoverW = None;
  fd_set init_fdset;
  /* ---------------------------- local functions ---------------------------- */

And sorry, I do not know something about programming, I just like to try out this or that an play with Patches like this one.

Hope this will help.

Thx & Greetings

My first though was that maybe, as these patches are applied in a cumulative way on the gentoo ebuild, it was failing because of any other previously added patch that the ebuild applies but you do not.

But grepping all the patches for events.c I found that only this one patches that file, so, that first though is not possible.

I can’t figure out what the hell is failing, but to fix it is trivial if you are compiling from source. The reject tells you what the patch command is searching and what is the line that it could not change/add.

The original snippet of code is as shown on above, and the final result is the one below, the line starting with ‘+’ tells you the line you have to add. The line numbers (158,163) tells you the original location of the snippet in the events.c file, but the code could be in a slightly different position if the file has been patched with any other additional patch outside this patchset or the cvs version is from a previous date.

Also, make sure you are not updating a local trunk that you got using cvs -D . It remains marked with that date making it impossible to update any further, I don’t know if it is your problem, if it’s the case, you would need to delete your local cvs copy and redownload it from the beginning.

Just some ideas.

@ 6thpink,
thank you very much, now it works!
After reading your instructions I`ve changed the following line:

Your Patch:

Index: fvwm/events.c
--- fvwm/events.c	(revision 12)
+++ fvwm/events.c	(revision 13)
@@ -158,6 +158,7 @@

And now:

Index: fvwm/events.c
--- fvwm/events.c	(revision 12)
+++ fvwm/events.c	(revision 13)
@@ -164,6 +169,7 @@

Youre right, its so simple … :slight_smile:

Now today`s cvs is working with all patches I like!

Thanks to all & Greetings


I have to edit this:
There was a little error in the patch and this error is the reason for the Problems:
This line is missing in fvwm/events.c:

fd_set init_fdset;  (somewhere at line ~163)

The Patch doesnt add this line, so I have played around with the patch und this Patch is now working correctly, tested with fvwm-2.5.21 and todays cvs-Source (for cvs you have to take a look at the lines and change them if needed):

Index: fvwm/events.c
--- fvwm/events.c	(revision 12)
+++ fvwm/events.c	(revision 13)
@@ -159,5 +165,7 @@
 int last_event_type = 0;
 Window PressedW = None;
+Window HoverW = None;
+fd_set init_fdset;
 /* ---------------------------- local functions ---------------------------- */

That`s it, is working clean here.

I think that that is your problem, the current cvs is 2.5.22, not 2.5.21, that might be the reason why the patch is failing for you, but I can’t confirm this either.

Anyway, it’s nice that you got it working. :slight_smile:

Can somebody please provide, those patch against 2.5.21 stable. That would be really cool. Thx a lot … 311.tar.gz

One of those patches doesn’t apply cleanly – I don’t have the time, or inclination or indeed interest to fix it. It’s one of the menu patches, so just don’t apply those. The others ought to work.

– Thomas Adam