Pointer automatically warps into titled submenus

Hello again,

I have a small problem with the fvwm menus.

I never used titled menus before, so it is surely something that I am missing, but it has bothered me for a few days and I can’t seem to find a way to “solve” this.

I have the PopupImmediately and PopdownImmediately MenuStyle options turned on, so, when I hover a menu entry xxxx whose action is Popup, it automatically pops without any delay. It the xxxx submenu does not have a title, this works ok. But if I define a title on that submenu with something like “AddToMenu xxxx XXXX Title”, when the submenu is displayed the mouse pointer automatically jumps to the first entry on the submenu (with “first entry” I mean the first menu item, not the submenu title). If this entry is a Popup submenu itself, it is also open instantly, which is very annoying, overall in slow submenus which are generated dynamically.

I know I could just define a delay but I wonder if I am missing something here. I would like the submenu to open instantly, but I don’t like my pointer warping into it automatically. I have tried !TitleWarp but as I expected that option did not help.

Anything obvious that I am missing? I have tried commenting out all the MenuStyle entries on my config and it does not help either. I have tried several other things and searched around, but haven’t found a solution yet.

Thanks in advance for any help.


You want the special menu option:

WarpTitle NoWarp

– Thomas Adam

Thanks, Thomas.

It seems to be a default, so, I am pretty positive that the problem was caused for any of the around 20 patches that my Gentoo ebuild puts into the source of fvwm. Plain 2.5.19 and current cvs honours that option (which the patched version does not) and current cvs does work as well. So, it is one -at least- of the patches.

I should have looked that the first thing. So, I apologize. It was my fault.

Anyway, thanks. To force the thing with that keyword and see that it would not work was what drove me to think that it was a bug. And when hunting bugs, the place to start is a patchset. I will take a look and remove a couple of patches, I think.


That depends on whether you use:

MenuStyle * Fvwm|Mwm|Win

– Thomas Adam

Yes, I saw that in the man page. Thanks for the clarification.

The source of my problems is a patch that I didn’t even know that it existed. It is called first-item-under-pointer or something like that, a smart move on my side hehe.

Thanks for all the help, Thomas. The issue is solved.