problem swallowing torsmo

Hi, I’m new in this forum, I think this question belongs to here. I was searching how to swallow torsmo in a FvwmButton, applied what I found but yet I can’t get it to work.

I’m using fvwm-crystal and I added the following lines to my own “recipe”:

DestroyModuleConfig FvwmTorsmo: *
*FvwmTorsmo: Rows 1
*FvwmTorsmo: Frame 0
*FvwmTorsmo: Columns 1
*FvwmTorsmo: Colorset 70
*FvwmTorsmo: BoxSize fixed
*FvwmTorsmo: (Swallow “torsmo” Exec exec torsmo -o -t '$nodename')

Style FvwmTorsmo Sticky, NoTitle, WindowListSkip, StaysOnBottom, BorderWidth 1
Module FvwmButtons -g 360x60+05-5 FvwmTorsmo[/code]

This is the resulting button ->

As you can see, or rather not see, nothing is shown, though torsmo is running.
Running the same command line from terminal I get this:

so I believe it’s not a problem of geometry, or something like that.

I would appreciate any tip on how to make it this work right.



Maybe it helps to set the orientation:

torsmo -a top_left -o -t '$nodename'

Btw the torsmo project is dead, but try out the new fork conky

It might be dead, but it still works.

The probem is more systemic than that. Look at this line in his config:

*FvwmTorsmo: (Swallow "torsmo" `Exec exec torsmo -o -t '$nodename'`)

What’s happening there is the shell is seeing $nodename in single quotes – no interpolation happens at that level, hence $nodename is parsed literally to tormso. I have no idea what that option does, but I bet that’s all it is, Just remove the single quotes.

See the following thread also:


– Thomas Adam

Thanks for the tips. The quotes seems to be actually needed, $nodename is a variable that both torsmo and conky recognize as the name of the machine.

I tried Conky, and it worked just OK. I could swallow Conky in a button in my little panel. Now it looks like this:

My code line for this is:

*DrivePanel: (11x1, Swallow "conky" "Exec exec conky -o -a top_left -t '$nodename con $sysname $kernel $time'")

Too bad ubuntu breezy package for Conky doesn’t seem to have Xft enabled. Time for compiling. (This was the reason I used torsmo instead, package did have Xft enabled).

Thanks for the help !


I’m curious about the following line:*FvwmTorsmo: (Swallow "torsmo" `Exec exec torsmo -o -t '$nodename'`) I notice that the name of the window in the provided graphic is “Torsmo”. I believe case is significant in the term after “Swallow”. You might try checking the output ofxprop | grep WM_CLASS If you see “torsmo” (with that lowercase T), then never mind.

In case the above was fruitless, do you mind sharing the definition Colorset 70? I seem to recall some difficulties with swallowed apps in FvwmButtons and colorsets, but its been awhile since I messed with the module, so I just might be misremembering.