"Read config" doesn't update running config most times

I’m running fvwm 2.6.8 on Debian 10, using LightDM as session manager. I’m having an issue where, after making changes to my config (for instance, adding a new item to my menu) and then I run “Read config” in FvwmConsole, about 9 times out of 10, the new config doesn’t take effect. If I log out and back in again, it works as expected.

I know I’ve done this in the past on Gentoo, and it worked every time, so I don’t suppose this is an issue with FVWM; I suspect something else is getting in the way of the command executing properly. However, I’m hoping someone can suggest where I begin troubleshooting this? I’ve tried adding lines to my menu to start and stop FvwmDebug like so:

+ "FvwmDebug"		Module FvwmDebug --log ~/.fvwmdebug
+ "Stop FvwmDebug"	KillModule FvwmDebug

But this doesn’t seem to work, as no file gets created at ~/.fvwmdebug. Or it’s only for bigger problems that I’m not having, and that’s why no file is being created.

Can anyone point me in the right direction please?

Hi @Cluracan,

Yes, don’t bother with FvwmDebug it won’t help you. Instead, find where FVWM is logging stderr and inspect that for any errors.

If it’s working by restarting fvwm, but not through Read then it will be something more subtle.

Send me your config and I’ll take a look.


Hi @thomasadam,

Sorry, I can’t see any method of messaging or e-mailing you through the forum. However, I’ve been using my FVWM config as a Gradle learning exercise, to see if I can make changes, upload to GitHub (for version control), and then “deploy” to my user profile, so it’s here on GitHub: https://github.com/JakeMoe/FvwmConfig

Let me know if you need anything further. Cheers,