Request for a .fvwm2rc file that works with high resolution laptops

I’ve posted a couple of questions on this forum, but haven’t been able to get a satisfactory solution to my problem. I’m running a Dell XPS 9300, which has a default resolution of 3840x2400, with ubuntu 20.04. The .fvwm2rc script that I’ve run for decades on laptops with resolution 1920x1080 generates windows that are unreadably small. The same is true with an out-of-the-box installation, using the config file that is shipped with fvwm, i.e., /usr/share/fvwm/default-config/config. Presumably, somebody has been able to overcome these problems. I’d really appreciate if if you could post, or send me (to leosimon@berkeley.edu) your .fvwm2rc file. Thanks very much for any assistance, Leo

Hi @LeoKSimon

As I’ve said before, this isn’t something FVWM is in control of.

To get anywhere with HiDPI you’ll need to:

  • Manually work out which font size(s) work comfortably for you, and apply them to your .fvwm2rc file. You’ll want to change things like:
DefaultFont ...
IconFont ...
Style * Font ...
MenuStyle * Font ...

The font size will scale the size of the titlebar, too.

That’s as much as you’re going to be able to get FVWM to look good. Everything else is application-specific – including the toolkits used to render things like buttons and their own menus.

I’ll again refer you here: HiDPI - ArchWiki

Thanks @thomasadam for your reply, and patience with my complaints. Since my last post, I tripped over what seems to be a magical solution. Having played around with resizing fonts, I found that it was all unnecessary, since

   xrandr --output eDP-1  --scale 0.5x0.5

resized everything I wanted to resize, so my screen almost like it used to look on my low resolution machines. The problem really was that the size of an fvwm page was now four time the size of the physical screen, so that, in particular, the RightPanel was not visible. Then the magic happened:

FvwmCommand Restart

restored the RightPanel to its rightful place, and it seems, shrank the Fvwm page to the size of the screen. Totally mystified as to why this happened, but I’ll take what I can get.

Things proved much trickier when an external monitor is attached. If I rescaled too soon, the external monitor blanked out, presumably because it couldn’t handle a 1920x1200 resolution, but when I rescale the laptop screen after the monitor is displaying correctly, then the monitor (which defaulted to 1920x1080) works fine also, in
all but one respect.

The only remaining problem I have is that the date and time don’t show up in the external monitor’s right-panel.
(It does show up on the laptop’s panel.) I fixed the time problem by locating an

xarclock

in the right panel.

But I’m stumped by the date problem. Can you suggest a simple fix, which would involve placing a black-on-orange
box below the clock, displaying, say,

date +"%a %b %d"

I’m sure this has to be the simplest thing to do in Fvwm, but I can’t find a sample to imitate.

A bit late to the party, but you can set the DPI of XFT fonts which can also help in some cases. On my 2k monitor the fonts were all a bit small, so setting the following in my ~/.Xdefaults increased the font size and thus window size.

Xft.dpi: 112

This increased all my fonts to a more reasonable size.

Thanks! I’ll try this on my next machine.