Session killed when using infostore

Platform : Linux mint Kataya on Toshiba Satellite L 300
I ran apt-get dist-upgrade a few minutes before the installation.

I removed my old install of fvwm 5.3.something apt-get --purge remove fvwm .
As root I compiled fvwm 2.6.4 ./configure && make && checkinstall
compile halted with error “/bin/mkdir” could not create directory “/usr/local/libexec”
So I createted the directory /usr/local/libexec/fvwm/2.6.4
Then checkinstall again.

That went smoothly, and fvwm runs fine - so far.
As I am curious about InfoStore I tested to type InfoStoreAdd abc 124 in FvwmConsole.
The WM dies and I am out to the login manager,

I rebooted and tested again - same result.
So I created a ~/.fvwm/config comtaining only this line InfoStoreAdd abc def , then I exited fvwm, went to the terminal and removed all crap from .xsession-errors.
Loggin in at fvwm, and the same thing happened again.

This is the first lines in .xsession-errors /etc/gdm/Xsession: Beginning session setup... Setting IM through im-switch for locale=sv_SE. Start IM through /etc/X11/xinit/xinput.d/all_ALL linked to /etc/X11/xinit/xinput.d/default. *** buffer overflow detected ***: fvwm2 terminated ======= Backtrace: ========= /lib/x86_64-linux-gnu/libc.so.6(__fortify_fail+0x37)[0x7f8e107281d7] /lib/x86_64-linux-gnu/libc.so.6(+0xfd0f0)[0x7f8e107270f0] fvwm2[0x47f29f] fvwm2[0x47f2c5] fvwm2[0x47f4a7] fvwm2[0x4634d5] fvwm2[0x47cbfd] fvwm2[0x47cd09] fvwm2[0x448528] /lib/x86_64-linux-gnu/libc.so.6(__libc_start_main+0xff)[0x7f8e10648eff]

The full list is at pastebin.com/JnK1Hr7L

I googled for “libc.so.6 (__fortify_fail+0x37)”, and get a few matches - the most of them are talking about that
there at the devolopers machine was other make tools than the ‘standard ones’ which was used to build the application in count.

I have empty partitions enough to do a fresh install of mint and try there, but I would like to hear some comments about this before I do that.

Also - both in mint Kataya and aptosid there was no Fvwm.desktop created in /usr/share/xsessions.
I solved this with reusing the old one - which I had on a backup.

/Peter

You shouldn’t be using checkinstall for anything. It’s deprecated.

As to fvwm crashing, you’ll need to compile fvwm with debug symbols, analyse the corefile and get me a backtrace, as in

make CFLAGS="-g"

Ok, I did make CFLAGS="-g", and after that the error does not occur.
So I tried- just for the sake of it, do a normal build ./configure make make install
And this time fvwm gets killed again when executing InfoStore.
Compiled again, with the make CFLAGS="-g" and now I can use fvwm again.

Quite strange, huh

/Peter

I have to add that I have not yet confirmed that InfoStore actually is working on my system.
I got some problems before (when I did the install first time . without checkinstall . and before trying to use InfoStore) which were solved when I used checkinstall. But the obvisually ones are gone now - but still, they could affect InfoStore.

For the moment I have been awake far to many hours to feel trust in myself to try it out. I come back with info later.

And as I am interested in getting the dependencies up to date, what should I use instead of checkinstall.? For now I can not use apt-get to remove fvwm (for doing a new install), because I installed it - as suggested, from source.

/Peter

None of this is helpful. I need a backtrace.

– Thomas Adam

I can not produce a backtrace when compiled with CFLAGS="-g", because when that done - running InfoStore does not crash fvwm.

I see no other choice than install a testversion of mint on another partition, install fvwm 2.6.4 from scratch before any updates and see if that works, keep track of the update progress and see if any of the updates triggers the error.

Any other/better ideas are welcome.

/Peter

Well, I cannot get this to crash at all, so I would try and find out what’s specific to your environment and fix it.

– Thomas Adam

I have now done a fresh installation of Linux mint 11 Kataya, and before running any updates I installed fvwm, and get the same error. Also on a fresh installation on Linux mint 12 Lisa with the same result.
However, after an apt-get dist-upgrade on mint 12 Lisa, there is no problem so far, but I have just rebooted and have this only line InfoStoreAdd qwe rty
in my .fvwm/config

I consider this as a bug to some package in mint Kataya and mint 12 before running dist-upgrade. I will probably test install Kataya on another computer, just to see what’s happen. I am also going to do the same in a virtual-box installation of mina Kataya.

Thomas
I will come back and tell If the error was reproducable in thoose environments

/Peter

I assume IInfostore is a typo here?

Yes, therefore I just edited :wink:

It seems that I did shout hooray to early.

That Install that I said I had no errors from, where InfoStore did not produce any error messages, well it seems that during the upgrade-progress my fvwm 2.6.4 got replaced with the version 2.5.something, therefore the command never got executed (because Thomas Adam just recently addaéd InfoStore to the 2.4.6 version).

Same thing there, both before and after I run dist-upgrade. fvwm dies and I sends back to the login manager. A core file was created IF I did not run the make with CFLAGS="-g", and IF I did run make with that flag, the error did not show up.

Also - I did run the same test within virtualbox, Linux mint 12 - but because my machine does not support hardware virtualization I had to install a 32 bit ver of Linux mint 12 Lisa on the vbox machine… Same problem both before and after dist-upgrade.

I will (hopefullly) during this weekend install mint Lisa 12 64 on another machine that I have in house.

I will before that, maybe today - do a new install of mint Lisa 12 32 on virtualbox, this time a kde-version in hope that It could be some gnome-packages that causes this error.

I appricate If someone that have mint whatever version, installed would like to try the command infostore.

Just open fvwcommand and input InfoStoreAdd somekey somevalue As I understand, it should be ok to copy and paste the exact string that I have in the code box above.

If you just have installed mint, those pastebin.com/mLL1gw8H are the packages needed to build fvwm. I Probably have some more packages than needed in that line, but it will give you a hint, The line below Is just some utlls that I use to install by default.

note about tk8.5 - you could also install tk8.4 if you prefer that.

I also add this one, pastebin.com/94drYt99 If you don’t get fvwm in to the login manager. Save the file as /usr/share/xssessions/Fvwm.desktop

/Peter

I now for sure can tell that InfoStore under mint 12 Lisa does not work on any of the two machines where I have tested it. And also not in Virtualbox. The error is the same on the two machines (different boards different bios, different cpu-archctetures (one of them intel - the other one amd).

The same error in both cases. When I in fvwmcommand run InfostoreAdd humpty dumpty , the session dies and I sends back to login screen. And when I built fvwm with the debug-flag that Thomas Adam suggested to produce a core-file, then the session does not die.

I also must admit that I have never tried to check whatever InfoStore really adds the values when running under the debug-compiled version. To be honest I feel a little bit - ehrm - tired about this.

I did try Install the KDE-version of mint 12 Lisa 32 in virtualbox, but that took so loooong time so I gave up. My best machine is to shitty to run the heavy KDE-installer in vbox. I am not sure that I very soon will try install KDE version on one of my other empty partitions (even though I know myself that I can not resist do that sooner or later, just to see IF that can help). But I have other priorities that must come in hand before that.

I will continue try to track down the error IF I can get some proper guidance.

/Peter

I wouldn’t bother trying.

At this point, I’d put this down to an emulation problem. No one else I’ve spoken to, even myself, can reproduce this on 32 or 64 bit machines.

– Thomas Adam

The other machine I installed on was a clean Install.

How many of the ones you have been spoken to is running mint 11 or 12 .?

/Peter

None – which is why I don’t care so much. If it’s a problem, it will be with this Linux Mint.

– Thomas Adam

I don’t know if I used the right words, but In my other machine it is not installen in vbox.
And also on this machine I have been trying NOT on virtual box on 12 different partitions . with mint 11 and mint 12.

Or did I misunderstand you phrase “emulation problem”.?

/Peter

I can think about two things why it should be a good idea to care.

One - If it is just because of Linux mint alone, then I need to fill a bug report for Linux mint so I and other users with that distrubition can continue to use fvwm. And that should be a good help both for fvwm and the Linux community if I could track the error down so I can fill it so the developers can do something about it.

Two - Mint uses some packages that might spread to the rest of the Linux world (for example, their great modifications to gnome3), so if the error does not get solved, others that are not shitty mint-users maybe will got that problem to.

Atleast, can you please give me some advices what I should have with me to fill a proper bug report (have never done that before).

/Peter

Bugreport created on bugs.launchpad.net/linuxmint/+bug/939890

/Peter