[SOLVED]:Debian repository install


I’m not sure I have the most up-to-date version of fvwm. I used the repositories (Synaptic, but it would have worked with aptitude, too), and it says I’m using “version 2,” or 1:2.5.30.ds-1. Is this the latest? If not, is it just a matter of downloading and installing the .deb package? Will that overwrite the version I have here, or just create a new one alongside it?

Also, as I mentioned in another thread, I have an amd64 architecture, and the downloadable packages I saw on the site for the latest version are i386 compatible. Is there a 64-bit version out there? Sorry to ask this twice, but I figured while on the subject…

Ok, I used synaptic to remove fvwm and fvwm-crystal. I then downloaded and unpacked the latest version. Did a ./configure, found I needed to install xorg-dev. Did that, ran ./configure again. Then, did a “make,” no apparent problems. Had to switch to root to do make install, did that, now when I log out and try to switch sessions in gdm, I don’t seen fvwm listed. What am I doing wrong?

Yes, replying to my own thread again.

Ok, I’m seriously lost here now.

I managed to get it onto the gdm, so I launched it. Got a blank screen, one desktop, six pages in a 3x2 grid, virtually nothing for a menu. Ok, it’s the default. Got it. So I manage to get thunar, leafpad, and my old fvwm2rc file open. I create a .fvwm directory, put the config file inside. Then, I click the menu, “restart fvwm” and… no change. None. Ok, so I move that out, click in the “Built-in menu” again, then click “Setup form.” It creates a bare-bones config file. Fine, but I STILL can’t get the file to work. I’ve gone in, changed a few things (arrangement of pages, colorsets, some basic mouse bindings, etc.) and I keep clicking “restart fvwm” in the menu, it keeps restarting, and… nothing. It’s like it’s not even reading the changes. Aruh?

This has nothing to do with fvwm.

Ok, I’ve figured out that I compiled it incorrectly, however, I’ve noticed that even a properly configured fvwm does NOT automatically put an entry onto the sessions list in gdm, so anyone who wants to switch back and forth will ahve to manually create a .desktop file for it and put it in /usr/share/xsessions.