[solved] Fvwm sometimes not reacting to window-managing keyb

From time to time, the focused window ignores keybindings to iconify/maximize etc. the window. Other keybindings like --behavior works fine. My terminal (urxvt) blinks, like if the keystroke was sent to the application (eg. -i). Clicking in the window, or changing to another one and back makes it react on the keybindings again.

It can happen to all applications, and I haven’t been able to track down any system in it.

Anybody got at clue?

Example keybindings:

Key I WT 4 Iconify Key M WT 4 Maximize Key Left WT 4 Move w-50p w+0 Key Right WT 4 Move w+50p w+0 Key Up WT 4 Move w+0 w-50p Key Down WT 4 Move w+0 w+50p

Sorry for my bad english

Have you tried other modifiers? Try and clear the whitespace before the function, too. It looks nicer that way :wink:
Do you by any chance have a FvwmEvent listener running?

Make sure that Num/Scroll/Capslock are not on. Or include “IgnoreModifiers L25”
in your config.

– Jesus Guerrero.

No FvwmEvent, L25 is in config, other modifiers doesn’t work as well, and my code is nicely formatted, at least when the forum doesn’t convert tabs into spaces… :slight_smile:

I found out that it happens every time i switch windows using a WindowList. See relevant code below. Don’t know why I couldn’t find out when it happened earlier. So after switching to a window using --etc., it ignores window-managing keybindings. Maybe something to do with window focusing?

I apologize that I was too fast with the first post. With this clarification, can anybody give me a hint?

[code]Style * ClickToFocus
Style * FPGrabFocus, FPReleaseFocus
Style * FPGrabFocusTransient, FPReleaseFocusTransient

MenuStyle ReleaseMeta SelectOnRelease Alt_L

Next terminal

DestroyFunc ShowClassList
AddToFunc ShowClassList

  • I CopyMenuStyle ReleaseMeta WindowList
  • I WindowList
    Root c c

MenuStyle ReleaseSuper SelectOnRelease Super_L

All other windows

DestroyFunc ShowOtherList
AddToFunc ShowOtherList

  • I CopyMenuStyle ReleaseSuper WindowList
  • I WindowList
    Root c c

MenuStyle ReleaseControl SelectOnRelease Control_L

Next icon

DestroyFunc ShowIconList
AddToFunc ShowIconList

  • I CopyMenuStyle ReleaseControl WindowList
  • I WindowList
    Root c c

Key Tab A M ShowClassList
Key Tab A 4 ShowOtherList
Key Tab A C ShowIconList[/code]

I found a workaround. It seems that the WarpToWindow entry in the default WindowListFunc confuses the focusing. So changing it into

[code]DestroyFunc WindowListFunc
AddToFunc WindowListFunc

  • I Iconify off
  • I FlipFocus
  • I Raise[/code]
    solves the problem. I have filed a bug.

This, I can’t reproduce, and I would put any amount of money on it being a crappy bug in the application. WarpToWindow won’t confuse focusing; that operation already happens with FlipFocus.

– Thomas Adam

Hmm… It happens with all my applications; even if I use the default config from FvwmForm-Setup from another user account. Maybe it has something to do with my Xorg-config or xmodmap, I don’t know. At least it works now…

I have written a more accurate description in the bug report. You still can’t reproduce it?

I’m on those mailing lists, remember. I might not reply, but I did read your email. Other than spending no more than about a minute with this, it’s not something I want to look into. Let someone else on the mailing list do all the hard work.

Cursory at least, this doesn’t seem like a proper fix at all for what is probably a completely different problem anyway.

– Thomas Adam

Glad to hear. You never know when your emails get caught as spam…

Agreed. I also stated that it was a temporary solution.

Thank you for your time…

In case anybody gets the same issue: The window buttons are not a part of the window title. So the “WT” context in the keybindings I used should be extended to include the visible buttons, in my case “WT1246”.