[SOLVED]Laptop: key bindings ignored when usb mouse plugged

Pretty self-descriptive: when I plug in a usb mouse, all the hotkeys, mouse bindings, just eveything stops working. When I unplug the mouse, everything works fine.

What can be done to this?

I think I’ll be fine with diasbling touchpad at all if necessary.

I’ll want to see some output from xev(1) before you plug the mouse in, and afterwards, for defined keys which work and then do not work.

– Thomas Adam

Here is ‘no mouse’ xev: pastebin.com/e34TW2FZ
And here I plug it in: pastebin.com/Bjk1GYJ4

Should I grep for anything particular?

//I’m hitting alt+tab and ctrl+grave there

No – but as I requested earlier, you can tell me which keys you’re pressing before and after (the same keys) which work and then not work having had the mouse plugged in.

– Thomas Adam

The case is not a single key works, but I’m hitting ctrl+grave, super+space and alt+tab, meaning to urxvt focus and raise, menu popup and window list on them correspondingly.


When the mouse is plugged in and I click either touchpad right button or mouse right button, it starts to work for a while - everything. But then ceases working again when I click Mouse 1, Mouse 2, Mouse 4 or Mouse 5… Than I click Mouse 3 and it starts working again.

Should I drop to default for more tests?

No, because it’s not an FVWM problem at all now that you’ve told me what I need to know.

– Thomas Adam

Allright then. Thanks for help!


As for April 2 2011 for Archlinux and Asus K50IN it’s solved with plugging in the mouse and running nvidia-xconfig. It would add a section for external mouse in a blink of an eye. Restart X and enjoy your mouse. )