[SOLVED] Logging message when starting fvwm

Hi everyone.

I just made a fvwm theme from scratch, sweeping stuff I like on a pile and filtering stuff out and so on.

Now I try starting it. I do it in these two ways.

Option 1: Startx Option 2: Startx fvwm2 > .fvwm/logs/20090418
I’m trying the second option for if I do it with the first, X is fired up, I get a black screen the cursor blinks, and then i’m at the console again. I then see tons of messages I’m willing to figure out, but I can’t scroll up to the first. So i’m trying the second option to grab everything. The file is made but it’s empty.

So what to do to grab all that output?

Umm, both options are wrong.

If you’re using startx, create the following file:

touch ~/.xinitrc && chmod +x ~/.xinitrc

… then treat it as a normal shell script@


program1 &
program2 &
exec fvwm -options

Then just launch:


– Thomas Adam

AH, I start fvwm now with “startx”. ONly because my config isn’t right in some places it gets the cursor and then “rollsback” to the console. I see a lot of messages and want to read them all instead of only the last.

Typically then you’d want:

startx > ~/.xsession-errors 2>&1

(Which some people choose to setup a shell alias for – but this is beyond the remit of these forums.)

But you’re really irritating me by not TELLING me what these errors are. In fact, in addition to you providing that information, also put your Xorg log file (/var/log/Xorg.0.log) in there as well. Use a pastebin for this, please. These forums are not a dumping ground.

– Thomas Adam

Thanks for that line. That did the trick. The out put is here http://pastebin.com/d1662aa05.

I didn’t tell the errors for two reasons, I apologize for that. They were

  1. I haven’t digged in to them myself
  2. I couldn’t grab them so would have to write them down and type them over

As you can see I need to do some stuff on depricated items, to less paramaters, and check the reference of some of my nested files. I made this using several configs on the web of which some were old. But hey, I need to start somewhere and go from there.

This is going to be a fun road to get it all working and how I want it.

Because I got the errors now I solved the post.

I think you’re special.

Just because you’ve got the list of error, that doesn’t mean you’ve now solved anything. In fact, from what you’ve outlined, you’ve completely missed the actual error which is causing your problems, namely:

waiting for X server to shut down .error setting MTRR (base = 0xd0000000, size = 0x10000000, type = 1) Invalid argument (22)

The rest of your FVWM errors are non-fatal, and you would have at least had a window manager running. So I would concentrate not on those for now, and look at the above error.

– Thomas Adam