[Solved] Mime-Type in Evolution under FVWM (no Icons)


I has a question to evolution.

I do not have Icons in evolution. He cannot find the Mime-Types

What can I make?

Many thank you.

Evolution is GTK-based, isn’t it? You probably want to fix your GTK-theme. Nothing to do with FVWM at all.

– Thomas Adam

Thanks for the fast answer.

under gnomes evolution runs perfectly.

Does FVWM need the Gtk support, for GTK of programs, and work FVWm with GTK 2.8.x

Under Gentoo is gtk 1.2 dependently for fvwm but i will use gtk 2.8.x

Many greetings Andreas

FVWM doesn’t care about GTK-apps. Only GTK apps care about GTK. Again, I suspect it’s an issue with your GTK-themes. Have a look at the “gth-theme-switch” program for starters.

– Thomas Adam


Thank you, i must start /usr/libexec/gnome-settings-daemon and Evolution is working.


This is more of a kludge than it is a fix. If this was just a case of missing icons, and wrong font sizes, then I am still going to maintain ~/.gtkrc-2.0 as the culprit here. While gnome-setting-daemon is a nice convenience, it’s completely over-board for running GTK apps outside of GNOME.

This is perhaps yet another reason why GNOME developers (especially Jeff Waugh) need to be shot on site. Aside from the fact that GNOME is a complete disaster in terms of HCI (Human Computer Interaction) and usability, where exactly is it the GNOME developers get off in thinking the G in GTK stands for GNOME? It’s a widget set that’s supposed to be agnostic – the sooner the GNOME developers realise this and remove half of the detritus they call code OUT of GTK, so much the better for every GTK app in existence.


– Thomas Adam

Quoted for truth. However, maybe a gentle pat on the head with a frozen log would do. :laughing: