[SOLVED]Pb with Libiconv.2.dylib


I had fvwm 2.5.21 installed for some time; everything was fine
until I upgraded another app called fink, and now fvwm won’t start.
Here is what I have in the fvwm-error file:

dyld: lazy symbol binding failed: Symbol not found: _locale_charset
Referenced from: /sw/bin/fvwm
Expected in: /sw/lib/libiconv.2.dylib

dyld: Symbol not found: _locale_charset
Referenced from: /sw/bin/fvwm
Expected in: /sw/lib/libiconv.2.dylib

There is a libiconv.2.lib in the path /sw/lib but it is a link to a library called
libiconv.2.4.0.dylib, which was created today. So I suppose that the fink upgrade
replaced the libiconv.2.dylib by libiconv.2.4.0.dylib, which is not fvwm compatible.

Can you confirm that in a standard fvwm install, libiconv.2.dylib is not just a link to
libiconv.2.4.0.dylib and what it should be ? Anybody encountered before such a
compatibility issue ? I would appreciate any hint about solving that problem,
thank you in advance.

Is this Mac OSX related?

Rebuild your FVWM against these new libs. I know nothing about Macs, but I suppose it can’t hurt to try.

– Thomas Adam

I rebuilt fvwm-2.5.21 and it works now.
I don’t understand where did the error come from though.
Thanks for your advice.