[Solved]problem with the Pager

Hi everyone,

i currently have a strange problem with my FvwmPager.
If i do a restart and i am on the first page of my Desktop everything works fine.
but if i do the restart on any other pages my FvwmPager vanishes.

( since i did a WindowListSkip ) on it i have no chance to reach the pager anymore, cause it seems that he is sticky on o other page on the +0+0 ( nordwest corner ) )

before i put the WindowListSkip option on it i coud reach the pager via the WindowList…

this is my configfile

in “myfvwm2menu” is just my popup menu defined. nothing else

Regard Martin

I can’t directly see what could be wrong, but can you tell me why you kill the FvwmPager module in your initfunction? That seems pretty weird to me…

My FvwmPager configuration looks like this:

##FvwmPager Style FvwmPager Sticky, NoTitle, StaysOnBottom, NoHandles, BorderWidth 0, Handle Width 0, WindowListSkip DestroyModuleConfig FvwmPager: * *FvwmPager: Geometry -0-0 *FvwmPager: UseSkipList *FvwmPager: Balloons *FvwmPager: MiniIcons *FvwmPager: Font none *FvwmPager: Colorset * 1 *FvwmPager: HilightColorset * 2 *FvwmPager: BalloonColorset * 2

Also I would be more inclined to use WindowListSkip directly on the FvwmPager module then on “Desk 0” as it is in your config, but I don’t think it should have anything to do with your issue.

i changed my config like you suggest ( the kill thingenie )

but this dosnt change anything. i had this in my config because some sample confs i have seen had this inside. i am pretty new the the fvwm2.

Alright I just tested you config and I’m pretty sure I’ve figured this out.

Your FvwmPager config looks like this:

But it should look like this:

[code]DestroyModuleConfig FvwmPager: *

Pager setup

FvmwPager: Font none
FvwmPager: Fore black
FvwmPager: Back gray77
#FvwmPager: NoSeparators
FvwmPager: Geometry “-0-0”
FvwmPager: ShapeLabels
FvwmPagerSmallFont "-adobe-helvetica-medium-r--

no hightlight

#*FvwmPager: NoDeskHighlight


*FvwmPagerHilight SlateBlue4
*FvwmPagerDeskHilight [/code]
The first line is very important, it should be used everytime you change a module’s config, when not using the “Style” command, that is.

i added this line to my config. didnt solve the problem :frowning:

( i have a suggestion for a workaround: i can put this line in my RestartFunction and add the FvwmPager things too ( didnt try if it works )

thanks for your time,

– EDIT –
in addition i want to say: i have no other config file on my system, the strange behaviour musst be my a bug or my misconfiguration…

Weird, I tried your config (with my menu’s of course), and after adding that line the pager showed up as normal, whereas otherwise it didn’t even show up on Fvwm start.


i tryed your change and my config on anouther PC of mine
( debian / testing with fvwm 2.5.10 ) same problem
my other laptop is gentoo with 2.5.10
which fvwm version are you using??

I’m using 2.5.12, I though I hears something about 2.5.10 being buggy, maybe an upgrade could sort things out?

hmm i thing ill first try to find a solution ( and ther must be one )
cause fvwm 2.5.12 is not in gentoos portage tree.

and thats why i think there must be a solution:
debian std config. tomorrow ill have a look at it. maybe i find the “importand difference” which causes my Pagers misbehaviour.

Thanks again for your time.

You could try my config, it works flawlessly with Fvwm 2.512 on Gentoo, and worked before with Fvwm 2.5.10 on both Gentoo and Ubuntu so I’m pretty sure it should work for you too. You can get it at my site in the Downloads section.

And yes Fvwm 2.5.12 is in portage, but it’s masked so you won’t ordinarily be able to install it, put this in /etc/portage/package.keywords (presuming you’re on an x86 architecture pc):

x11-wm/fvwm ~x86

That should enable you to merge Fvwm 2.5.12.

ohh thank you happy
ill compile the new fvwm and test the config files of you and std. debian and mine, i am pretty sure ill find it!!!

ill write more, if i know the cause!


Oh, I have found why it wasn’t working.
It was

*FvwmPager: ShapeLabels

when I comment this line it works fine (but I still don’t know why).

Iirc ShapeLabels can be used to “shape” labels into nearly arbitrary forms by using an image as a mask. It might have been causing problems because it wasn’t used, it was wrongly configured or not configured at all…

Generally it’s a good idea to kick everything you don’t use out of your config when you have problems because it just might be causing problems.

Well, I’m happy you were able to resolve it, now you can start to enjoy Fvwm I would say :slight_smile:



Well, that solved my pager problems, too. Thanks a lot!