[SOLVED] Some weird problem

I config is pretty much separated on many files
It used to be OK, untill today, when i decided to make another file dedicated to menu (separated volume control)


~/.fvwm/Config/menus/User.conf (just part… this file works well)


When i start/restart fvwm ~/.fvwm/Config/menus/Sound.conf should be read, but it’s not
It never makes menus called MenuMixer, MenuMixerCD…

BUT, when i coppy paste line from ~/.fvwm/config that says that ~/.fvwm/Config/menus/Sound.conf should be read
Everything works great…

How can it be?
What did i miss?
Menu names are correct, it was working until i made a separate file for sound menu
I added new line in config, so that new file should be read on startup
And when i read file manually using EXACT line in console it works

I run FVWM 2.5.26 on FreeBSD 7

PS if you want me to post entire config to try and reproduce, Let me know

Also i put that line last, to make sure, there’s nothing that deletes MenuMixer and yet no success

So look in ~/.xsession-errors for anything obvious.

Whilst I don’t see anything obvious from what you’ve posted, upload in a tarball or something your entire config – it’s likely something somewhere is overriding something else.

– Thomas Adam

$ less ~/.xsession-errors
/home/killasmurf/.xsession-errors: No such file or directory

The onous is on you there. Either way, however you start up FVWM, ensure you do:

exec fvwm > ~/.somefile 2>&1

That might actually be useful.

– Thomas Adam

just tried what you suggested

$ less fvwm.log [fvwm][ParseBinding]: <<ERROR>> No such key: XF86AudioMedia exec: trayer: not found fetchmail: can't accept options while a background fetchmail is running.

Nothing important here

So get me my tarball of your files.

– Thomas Adam


Here it is

UserApp.conf and pick your favourite editor
after that you can edit any configuration file when you press CTRL+Mouse1

Menu will appear.
Rest is easy to figure out

Eh? I get redirected here when following that link:


– Thomas Adam

Dam, hold on, i will edit my homepage and add link on main page.
you will be able to download then 100%


can you download it now? (you should)

EDIT… i copied file ~/.fvwm/Config/Sound.conf content back to ~/.fvwm/Config/User.conf, where it originally was. and everything works again
But i really want it separated

It all works fine for me – i get the menu created just fine adding in a reference to Config/menus/Sound.conf – no idea why it fails for you, works fine for me.

– Thomas Adam

Now that is weird, and i even got read permissions (as i should)

Edit: Even when i Read it in console (it works) and then Delete it (also in console), and restart fvwm with function, if fails
Is there any kind of update menus function?

EDIT2: for some reason in my ~/.config there was no line that reads that dam file (how the hell it dissapeared… i was pressing ctr+s many times)

Ok, weir, but solved

EDIT3: I hope it’s not HDD problem