some issues with my configuration


I came back to Fvwm and feel how it’s cool.
I lost my old configs. So I decided to write new config from the scratch.
I have some problems with Fvwm which solutions couldn’t find here or in FAQ or man (well…;D).
Here are my problems:

  1. Problems with WindowList
    a. How can I raise a window during selection? I wish to highlight window (raising it, or highlight just border).
    I tried to add to WindowListFunc:

[code]AddToFunc WindowListFunc

  • I Current Raise[/code]
    But WindowListFunc works after selecting :frowning:

b. I wish to see windows only from CurrentPage.

Key Tab     A       M   WindowList (CurrentPage)

It works but I wish to send current window at the end.

Key Tab     A       M   WindowList (CurrentPage), NoGeometry, CurrentAtEnd, IconifiedAtEnd

It doesn’t work correctly

Key Tab		A		M	WindowList Root c c CurrentDesk, NoGeometry, CurrentAtEnd, IconifiedAtEnd

This code works fine, but it’s for CurrentDesk ;/

2. Problems with resizing windows

[code]DestroyFunc ResizeFunc
AddToFunc ResizeFunc

  • “M” Resize[/code]
    a. This function works fine but only if you want to increase the window. If you want smaller window, first you have to move a pointer to the window’s frame. Is it possible to decrease a window without moving pointer to the border first?

b. I like geometry information during resizing. But this info appears in top-left corner of the screen. How to place it at the center of the resizing window?

c. Is it possible remove grid? Just to have frame while resizing?

3. Menu
a. I use TrianglesSolid and they apper only if i’m currently on popup position. so normally they are hidden. how to show them up?

b. I wish to have one menu with automagic-generate menu. Something similar to GNOME/KDE/etc menus…with categories of applications. How to do that?

4. Thumbnails
a. How to set spot on the desk where thumbs should be placed?

b. The icon above screenshot doesn’t appear. What is wrong?

[code]DestroyFunc Thumbnail
AddToFunc Thumbnail

  • I Raise
  • I ThisWindow (!Shaded, Iconifiable, !Iconic, ) PipeRead
    “xwd -silent -id $[] |
    convert -resize $[ThumbWidth]x$[ThumbHeight] -frame 1x1
    -mattecolor black -quality 0
    xwd:- png:$[ThumbDirectory]/icon.tmp.$[].png
    && echo WindowStyle IconOverride, NeverFocus
    Icon $[ThumbDirectory]/icon.tmp.$[].png
    || echo Nop”
  • I Iconify[/code]

You can’t.

You have an extraneous comma, c.f.:

Key Tab     A       M   WindowList (CurrentPage) NoGeometry, CurrentAtEnd, IconifiedAtEnd
Key Tab		A		M	WindowList root c c CurrentDesk, NoGeometry, CurrentAtEnd, IconifiedAtEnd
+ M Resize  Direction SE warptoborder
Emulate MWM


Give your menustyle a hilightcolorset.

See the: fvwm-menu-desktop command.

You can use:

Style someapp IconBox x y z a, IconFill t r, IconGrid 0 1

That function uses:

Icon $[ThumbDirectory]/icon.tmp.$[].png

Is ThumbDirectory defined? It’s superfluous anyway, see:


– Thomas Adam

Is there any (unofficial) patch or anything?

For every application? I’ sure that I had just one line where i set start position for thumbs (another goes verticaly below)

ThumbDirectory is defined. I got thumbs with screenshot of the window (so it has to be defined). the only problem is with the icon above screenshoot.
It should be done by code below:

&& echo WindowStyle IconOverride, NeverFocus \ Icon $[ThumbDirectory]/icon.tmp.$[].png \
Shouldn’t be? Or I wrong understand meaning of this code.
All I want is the screenshot and icon of the app in the top-left corner :slight_smile:

MenuStyle * MenuColorset 10, ActiveColorset 11, HilightColorset 1
[FVWM][NewMenuStyle]: <> unknown option ‘HilightColorset’

See: IconFill.

– Thomas Adam

There’s an unofficial patch to set thinner borders. I think it also removed the grid, but not sure.

Doesn’t work. I’ve tried an example from manual pages.

            Module FvwmGtk
            *FvwmGtk: Destroy gnome-all
            *FvwmGtk: Menu gnome-all
            *FvwmGtk: Title "Gnome Menus"
            *FvwmGtk: Separator
            *FvwmGtk: Destroy gnome-sys
            *FvwmGtk: Submenu "System" gnome-sys
            *FvwmGtk: Destroy gnome-user
            *FvwmGtk: Submenu "User" gnome-user
            *FvwmGtk: Destroy gnome-redhat
            *FvwmGtk: Submenu "RedHat" gnome-redhat

            PipeRead ’fvwm-menu-desktop --type gtk --enable-mini-icons --icon-folder :re --icon-app :re --icon-title :re --icon-toptitle :re’

            PipeRead ’fvwm-menu-desktop --type gtk --desktop gnome-user --enable-mini-icons’

            PipeRead ’fvwm-menu-desktop --type gtk --desktop gnome-redhat --enable-mini-icons’

I get a menu with empty sub-menus (system, user, redhat).

I can’t search for this because ‘fvwm-menu-desktop’ is too common :wink:

Works fine here.

– Thomas Adam

I have the same problem… the command “fvwm-menu-desktop” just gives me empty menus. I am running FVWM on multiple Fedora 10 machines and each exhibits the same behavior.

How are you invoking fvwm-menu-desktop? And what, if I want to reproduce this, would I need to have installed as pre-requisites?

– Thomas Adam

Running “fvwm-menu-desktop” in a terminal gives me the following two lines:
DestroyMenu “gnome-sys”
AddToMenu “gnome-sys” “Gnome System Menu” Title

No prerequisites…

fvwm 2.5.26 compiled on Aug 30 2008 at 13:20:30
with support for: ReadLine, Stroke, XPM, PNG, SVG, Shape, XShm, SM, Bidi text, Xinerama, XRender, XCursor, XFT, NLS

Ok, so I took a very quick cursive glance at the code and came up with this (from FVWM CVS – although if you’re smart enough, you can just edit “$(fvwm-config -B)/fvwm-menu-desktop)” and apply this:

diff --git a/bin/ b/bin/
index d41d281..4f72db6 100644
--- a/bin/
+++ b/bin/
@@ -233,7 +233,7 @@ $DESKTOP = 'Kde'   if ( $MENU_NAME =~ /kde/ );
 $DESKTOP = 'Gnome' if ( $MENU_NAME =~ /gnome/ );
 if ( $OPT_INSTALL_PREFIX ne '' ) {
-       $APPS_DIR = $GNOME_APPS = "$OPT_INSTALL_PREFIX/share/gnome/apps";
+       $APPS_DIR = $GNOME_APPS = "$OPT_INSTALL_PREFIX/share/applications";
        $KDE_APPS = "$OPT_INSTALL_PREFIX/share/applnk";
        $KDE_MINI_ICONS = "$OPT_INSTALL_PREFIX/share/icons/mini";
        $KDE3_MINI_ICONS = "$OPT_INSTALL_PREFIX/share/icons/hicolor/16x16/apps/";

This is completely untested though, but the output does produce valid syntax for a menu related to GNOME at least.

– Thomas Adam

Edited /usr/bin/fvwm-menu-desktop according to your post, now I get:

[nstickney@elijah ~]$ fvwm-menu-desktop Can't modify negation (-) in scalar assignment at /usr/bin/fvwm-menu-desktop line 236, near ""$OPT_INSTALL_PREFIX/share/gnome/apps";" Execution of /usr/bin/fvwm-menu-desktop aborted due to compilation errors

I’m not much good with perl… by which I mean I’ve never used it before, so I’m pretty lost. Any thoughts?

[nstickney@elijah ~]$ perl -v

This is perl, v5.10.0 built for x86_64-linux-thread-multi

No, silly! I didn’t realise you were going to take that literally! What I gave you was a patch – the - and + symbols indicate lines(s) removed (-) and lines added (+) – they’re not part of what you should add.

So, this time, the line which looks like:

$APPS_DIR = $GNOME_APPS = "$OPT_INSTALL_PREFIX/share/gnome/apps";

Before you edited it, should be replaced with this line:

$APPS_DIR = $GNOME_APPS = "$OPT_INSTALL_PREFIX/share/applications";

Go read up on patch(1) and diff(1).

– Thomas Adam

:astonished: /me smacks self in forehead

Duh, thanks!

So can you confirm if it is at least doing something now?

– Thomas Adam

Nevermind, this fix is in FVWM CVS.

– Thomas Adam