starting fvwm when startingx, other ?s

Okay so I did a fresh install of my distro, gentoo.
I emerged fvwm-crystal
I want to have fvwm start instantly when I start X
I tried first doing echo fvwm-crystal > ~/.xinitrc
That didn’t work
Then I tried adding “exec fvwm” to the ~/.xinitrc file itself
Now, it started. But it’s WEIRD
It’s not the normal config that I saw before when I used fvwm-crystal when I had gnome running as default (note I didn’t emerge gnome this time)
Now, there’s no menus on the desktop, no list of active windows, no nothing.
The only thing it has is when I click the mouse
The menu popus up

Builtin Menu
Startup Form
Setup 95 script
Issue FVWM commands
Restart FVWM

I tried loading
This config
in my /usr/share/fvwm file so it loads for both my root and my user account.
But nothing is changing.
So I tried putting it just in my /root and /home/moon accounts using

I don’t understand it.
What stupid thing am I doing this time to get this wrong?

exec fvwm2

not fvwm

Greets, Mark

MIJ, okay I put exec fvwm2 there but it still hasn’t changed to the .fvwm2rc config file I created.
Why not?

try forcing it with -f. The newest version of fvwm expects ~/.fvwm/config rather than ~/.fvwm/.fvwm2rc

do you have any errors? check the console

this time using exec fvwm-crystal worked.
Now I’ve gotta figure out why xmms wont load.

You might need to run a sound-daemon in .xinitrc

exec /usr/bin/esd -terminate -nobeeps -as 2 -spawnfd 17 &

So you must install esd (the enlightenment sound daemon).
This was used by gnome 2.4 too on Linux-Mandrake, so I took this line from the Gnome-configs for fvwm.

Greetings, Mark

Careful – fvwm prefers ~/.fvwm/config but it does not yet require it. A distinction that’s important. It may well be that ~/.fvwm/fvwm2rc as a filename is dropped in future versions, although I doubt it, given backward-compatibility reasons.

– Thomas Adam

I could have sworn I had a config that refused to start after the last version upgrade. Nothing worked until I switched to using “config”.

That said - I’ve seen the source. It sure looks like it takes .fvwm2rc still…