Still cannot maximize windows in IconMan

I am still having problems with maximizing the windows thats in the FvwmIconMan. I found this in another config file:

*FvwmIconMan: Action Mouse 1 N sendcommand FocusRaise

DestroyFunc FocusRaise
AddToFunc FocusRaise

  • I Iconify False
  • I Focus
  • I Raise

I have put that in my own fvwm2rc file but nothing happens if I click on a window in the FvwmIconManager (have tried all mouse buttons).

Works fine here. Anything in ~/.xsession-errors that would indicate why it isn’t working? Just out of interest, the same thing can be achieved as:

*FvwmIconMan: Action Mouse 1 N sendcommand "Iconify", sendcommand "Focus", sendcommand "Raise"

Does that line work for you?

– Thomas Adam

That does not either. I have tried to reduce the FvwmIconMan to this:

AddToFunc StartFunction
+ I Module FvwmIconMan

Style FvwmIconMan Notitle
*FvwmIconMan: 1 ManagerGeometry	500x1+200
*FvwmIconMan: 1 ButtonGeometry		2x24
#*FvwmIconMan: Action Mouse 1 N sendcommand FocusRaise

*FvwmIconMan: Action Mouse 1 N sendcommand "Iconify", sendcommand "Focus", sendcommand "Raise"

But still nothing happens when I press one of the Icons in the IconMan

Why do you have the number “1” after “FvwmIconMan:” ?

– Thomas Adam

I just looked in the .xsession-errors and the last entries look like this:

[FVWM][GetWindowSizeHints]: <> The application window (id 0x2404285)
“Information - Konqueror” has broken size hints (max_width).
fvwm is ignoring those hints. If you are having a problem with the
application, send a bug report with this message included to the
application owner. There is no need to notify
hint override = 0, flags = 23f
min_width = 351, min_height = 106, max_width = 350, max_height = 105
width_inc = -1073749256, height_inc = -1073749576
min_aspect = -1226282172/148456960, max_aspect = 148437344/-1227035417
base_width = -1222019472, base_height = -1222019472
win_gravity = 1

[FVWM][style_parse_and_set_window_style]: <> Bad style option: WindowSkipList
[FVWM][Read]: <> file ‘/ect/X11/fvwm/menudefs.hook’ not found
[FvwmIconMan][FlocaleGetFontSet]: (--fixed-medium-r-normal–13-) Missing font charsets:
KSC5601.1987-0, GB2312.1980-0
[TestPager][FlocaleGetFontSet]: (5x8) Missing font charsets:
JISX0208.1983-0, KSC5601.1987-0, GB2312.1980-0, JISX0201.1976-0, ISO10646-1

It seems to have something to do with FVWM, but I have no experience with these kind of errors.

There’s nothing you can do about this. It’s a problem with KDE (surprise, surprise.)

WindowListSkip is what you should use.

– Thomas Adam

Ok but it worked fine in FvwmTaskBar so I guess I will go back to that, damn what a waist of time :cry:

I also just tried with a regular xterm and that will not maximize either so I would not blame KDE. Must be something in the FvwmIconMan module, because as mentioned it works fine with FvwmTaskBar