stop gaim from getting focus when new message arrives?

Every time gaim gets a new message, it pops up and the mouse goes to it and the cursor goes to it. That’s very annoying. How do i get fvwm to not send the mouse and focus to gaim when a new message arrives? I have it to not do that already in gaim.

[color=red]Edited by theBlackDragon:
–> Moved from Basic questions[/color]

It sounds as if gaim is using the urgency hint. (What you describe is fvwm’s default urgency function:

AddToFunc UrgencyFunc

  • I Iconify off
  • I FlipFocus
  • I Raise
  • I WarpToWindow 5p 5p

You may redefine that function in any way you desire.

can you tell me what it needs to look like to do what I need? I don’t have that function in my config and I’ve never seen it before. Pardon my ignorance :smiley:

You don’t need to do anything to that fvwm function, he’s just telling you that gaim is indirectly calling that function. You could edit it, but that would impact any program that makes use of it (so probably a bad idea). Look closer at your gaim preferences, you haven’t turned off the urgency hinting like you claim.

Might be the same problem as mentioned in the last post of this threa :slight_smile:

Ooooooh. Well, that might be it too :wink: Although, I still don’t get why that would happen when I turned off “Raise window on events” in the prefs. But, if it works…