strange window focus behaviours


I’m a rather happy windowmaker user, but sometimes it’s good to change for a while, and I like very much what we can achieve with fvwm, it’s a very powerfull window manager, even if a bit tricky to configure.

I liked the transparency effect on some of those themes, and then I decided to create my own buttons based on this config files :

I changed the default behaviour of SloppyFocus to this :

Style * ClickToFocus
Style * TileCascadePlacement, MinOverlapPercentPlacement
Style * DecorateTransient


It’s working well, but sometimes it ends I can no longer have focus to some windows : the title bar stay as it’s unfocus, however it’s above the others. I can click on things in it, but can’t type with keyboard, the focus stay for ex. on a console. If I kill the console and stay with only one application the focus move to this application. If I start another application, the previous one loses the focus and can’t get it again. This behaviour ends until I restart the X server ( Then it’s working well, until the problem occurs again at, it seems, random occasion.

Is this an identified issue ?

My machine is on debian unstable, PPC linux.
fvwm 2.5.13 compiled on Jul 20 2005 at 05:32:21
with support for: ReadLine, RPlay, Stroke, XPM, PNG, Shape, XShm, SM, Bidi text, Xinerama, XRender, XFT, NLS

It is, yes. It’s predominately visable when using SloppyFocus as well.

– Thomas Adam

Just to make sure that you haven’t fallen into the same bearpit that I once did :wink: is to check your configuration for following line:
Style “Fvwm*” StaysOnTop, NeverFocus etc.
Because, naturally, that prevents windows such as “Fvwm Forums” to get focus … :wink:

I’m coming on this thread again, I’ve tested fvwm (debian, linux x86) at my office, and it’s even worse than at home, I get this problem as soon as I start the window manager.

I looked in my config files, there is nothing related to StaysOnTop, NeverFocus

Is there a workaround ?
I can only switch back and get the focus to the previous window if I select it in the “list of windows”

That no longer sounds as the bug Thomas mentioned, I am pretty sure something is very wrong in your configuration file, try going over it and commenting out Styles and lines to do with focus until you’ve found the culprit, there’s not really anything else I can recommend you do…

ok, I’ll try this, even if it will be a huge work because it’s based on

What is really strange is I’m using this style right now on my laptop and it’s working fine, except when it randomly gets the problem, but it’s generally after a few time / hours. On the other computer, it’s immediatly after starting the X server. I’ll search further, and will remove what is not necessary in this style.


I think I understand now :

" Why do NumLock, CapsLock and ScrollLock interfere with
ClickToFocus and/or my mouse bindings?

A: Because they are treated as modifiers. You can use the
IgnoreModifiers command to turn individual modifiers off for

:smiling_imp: :smiling_imp:

So that was it? Wow, you put us off track pretty good then… :open_mouth:

I pushed by mistake the num lock of my keyboard and experienced the problem again. Then I found this explanation in the FAQ. I think it will be the same at my office, I just hope I’ll be able to use the numeric pad there, or I’ll manage to desactivate the correct key.

Thank you for your previous advices and suggestions anyway.

Rest assured, IgnoreModifiers will not interfere with the normal working of the numpad, it’ll only turn off the use of NumLock as a modifier (Same goes for the other *Lock keys btw).