Use jpg MiniIcons rather than .png miniIcons

I’m trying to set my MiniIcons in my taskbar with a variety of icons, using the command

FvwmCommand "Current (*) WindowStyle MiniIcon $icon"
where at the moment $icon is a .png file. It appears that unless my .png file is less than 1K in size, the icons simply don’t show up, it’s as if I hadn’t specified any icon. Unfortunately, the range of .png icons i can find that are under 1K is size is really small, and .png files can’t be compressed very much. So I’ve tried with jpg files but when I use the above command with a jpg icon, nothing happens. Of courese, FvwmCommand doesn’t generate an error message, so I don’t really know what’s going on. Is there any way to get around this problem, i.e., either some way to use .jpg icons, or some other kind, or else use larger icons and have them show up in the tiny space that’s available to them?

Thanks for any suggestions.

Fvwm only supports the image formats .png, .xpm and .svg. There is currently no support for other formats such as .jpg.

I was not aware of a size limitation on MiniIcons, and I just tested, a 1.2k miniicon and it worked just fine.

I also tested a 37k icon, and it worked (though I didn’t see the whole icon, only the corner because the image was far bigger than the area fvwm had set up for the MiniIcon).

Fvwm does not resize .png images, so the icon may just need to be resized to be correct size (imagemagick convert command can do this). Also why do you want miniicons much bigger than 1k? MiniIcons are small and are used in various things like the title, fvwmiconman, menus, and so forth. They do not need to be big images.

If you want fvwm to be able to scale images, you will have to use .svg format.


Thanks for your response jaimos! Since my first posting I’ve found a bunch
of .png icons that are no larger than the ones that have worked. These tiny
miniIcons don’t work, i.e., when I type the command

FvwmCommand “Current (*) WindowStyle MiniIcon $icon”

where $icon is the name of a .png icon, on the xterm title bar, there is a blank
space where the icon should be, and on the menu bar, no icon appears.

As far as I can tell, the tiny .png file is no different from the .png file that
does give me an icon, and FvwmCommand provides no error information.

Is there any way at all to debug this situation?

Thanks for your help!

Fvwm logs to stderr by default, where this is kind of depends on how you started Fvwm. If you used startx this might be the console you typed startx on, otherwise it might end up in a file called $HOME/.xsession-errors .

If you want to check where it ends up you can just use the Fvwm “Echo” command and see where the output ends up.