Window move stalls with Vivado


I’m seeing an issue but only when I run Xilinx’s Vivado FPGA tool. Sometimes, usually about once a day, moving a window stalls. By stalls, what happens is this:

  1. I place the mouse over the title bar of a window.
  2. I press and hold the left mouse button, the title bar “depresses”.
  3. I start moving the window.
  4. The mouse icon turns from an arrow to a hand and the window moves.
  5. I continue holding the left mouse button and moving the mouse, but after a short distance the window stops moving as if I had released the left mouse button. However, the mouse continues to move and the title bar of the window I was moving is still depressed. The contents of all windows seem OK.
  6. I release the left mouse button but the mouse icon remains a hand and the title bar of the window I was moving stays depressed. I cannot interact (grab, move, type, etc…) with any window but I’m able to move the mouse. I use “focus follows mouse” but the focus does not follow the mouse at this point.
  7. After a time period (30 seconds or so), everything returns to normal and I can interact normally (move, type, etc…) with windows again. I can get a more accurate time if it’s helpful.

This is more an annoyance than anything else, since it occurs about once a day when running Vivado. I see the problem when moving a variety of application or terminal windows, including Vivado windows. This only happens with running Vivado, and Vivado may be iconified or not. I’ve tried several mice, so I don’t think it’s an issue with a flaky button.

I’m running FVWM3 1.06a and Vivado 2021.2.