Wrong desktop size (?) after upgrade to debian bullseye

Hi,

After an upgrade from debian 10 to 11, maximizing windows leaves around a centimeter of space on the right side of the screen, while moving windows to the right using a binding (Move -0 keep Warp) does the same.

I realize this might not be an fvwm issue; the fvwm version - 2.6.8 - hasn’t changed, though on my upgraded system it’s compiled a year later than the 2.6.8 on another computer still running debian 10. My .fvwm2rc hasn’t changed either.

On the other hand, starting programs from the terminal with a specified -0-0 geometry does put them all the way at the right edge of the screen, and the wallpaper, which is set by feh, also covers the full screen. So it seems like fvwm might be getting display size information in a different way, and that way might be dependent on something that’s changed in the upgrade?

Any suggestions for what I can look at to track this down would be very much appreciated.

For what it’s worth (I apologize if this isn’t relevant) xrandr gives me:

Screen 0: minimum 320 x 200, current 1366 x 768, maximum 16384 x 16384
LVDS-1 connected primary 1366x768+0+0 (normal left inverted right x axis y axis) 277mm x 156mm

FvwmIdent on a “maximized” window gives:

Width: 1308
Height: 758
X (current page): 0
Y (current page): 0
Boundary Width: 5
Geometry: 858x663+0+0

If I move the window manually to the right edge of the screen, FvwmIdent gives the new X coordinate as +48.

DeskTopSize is 1x1. If I run a Pager, it shows the little strip of space at the right of the desktop that’s uncovered by open maximized windows.

Do you set EwmhBaseStruts or use the default-config (or is your config based off the default-config), since the default-config uses EwmhBaseStruts to reserve a bar of area on the right edge of the screen?

What you describe sounds like you have EwmhBaseStruts configured which is acting appropriately.

Hi somiaj,

There’s no mention of EwmhBaseStruts anywhere in my .fvwm2rc. (Also, I’ve been using versions of the same rc file for almost 20 years, and this is a new behavior.)

Is it possible that some EwmhBaseStruts configuration may have been turned on elsewhere?

Update: Based on your post I added
Style * EWMHIgnoreStrutHints
to my rc file and now afaict things are back to normal. Thank you!

Out of curiosity, any idea why this might have become necessary? Where does fvwm look for config information besides my own config file? Or could this be related to a compiler setting?


last update: Reading the fvwm man page some more I saw that struts can get defined when applications ask for them. Because wicd was removed from debian 11, I had to install stalonetray to be able to run Network-Manager… and while stalonetray launched as a tiny thing that I could immediately close, apparently it did reserve space at the right of the screen. I didn’t think of it because I didn’t have it running when I noticed the maximization problem. Ridiculous, but I’m glad at least I understand it now (and that there’s a stalonetray setting to not use struts).

Thanks again for your help!