xosview in taviso's shelf misbehaving?

Hi guys,

this screen shot should speak for itself - I see the xosview monitors initialising on startup and then getting swallowed in the shelf but the display is poor and I don’t know how to go about configuring the font size or settings so that it looks the way it should in taviso’s screenshots.

as you can see from the other items I am struggling to get the icons working despite downloading and including in my path the tar.gz pointed to in taviso’s latest beta config download thread… I suspect that something is not being found and default text is being dumped in a cramped space…

if anyone can recognise the problem I would appreciate some help - otherwise I will continue to search and climb the learning curve!


It’s a setting with your XServer’s font DPI in /etc/X11/xorg.conf – try changing the order of the font lines (swapping 75dpi over for 100dpi) – the order they’re listed in is the order they’re searched in.

You should also check to see what the -dpi value is when it is passed to the XServer as it starts up – it’s in a file in /etc/X11 somewhere.

– Thomas Adam

Thanks ThomasAdam,

I have done as you recommend and made this change to the beginning of my xorg.conf

Section "Files"
        FontPath        "/usr/share/X11/fonts/misc"
##      FontPath        "/usr/share/X11/fonts/cyrillic"
        FontPath        "/usr/share/X11/fonts/75dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/100dpi/:unscaled"
        FontPath        "/usr/share/X11/fonts/Type1"
        FontPath        "/usr/share/X11/fonts/CID"
        FontPath        "/usr/share/X11/fonts/75dpi"
        FontPath        "/usr/share/X11/fonts/100dpi"
        # paths to defoma fonts

but this has not helped so I found:

XOsview in app-defaults

! **********************************************************************
! **********************************************************************
! **  DO NOT EDIT Xdefaults!!!!
! **
! **  Only make changes to the file Xdefaults.in, and re-run ./configure
! **  to regenerate Xdefaults.
! **
! **  Thanks,
! **    the Management :)    (bgrayson)
! **
! **********************************************************************
! **********************************************************************
!  xosview resources (override into your .Xdefaults file)
!  $Id$

! General Resources

!xosview*geometry:           +5+5
xosview*captions:           True
xosview*labels:             True
xosview*transparent:        False
xosview*meterLabelColor:    wheat
xosview*usedlabels:         True
xosview*usedLabelColor:     wheat
xosview*borderwidth:        0
xosview*font:               7x13bold
xosview*background:         navy
xosview*foreground:         wheat
xosview*enableStipple:      False ! Change to true to try beta stipple support.
xosview*samplesPerSec:      10    ! not yet supported
xosview*graphNumCols:       128   ! number of samples shown in a graph

and I tried changing the 7x13bold to some other values despite the warning not to edit manually - I must read up on the process of reconfiguring with ./configure and how to specify Xdefaults.in - all new to me. I suspect this is the file you are refering to. Thanks for the pointers.


You can also put something along the lines of

Xft.dpi: 96

in ~/.Xdefaults which is what worked for me :slight_smile:

Nothing to do with ./configure. If you change ~/.Xdefaults whilst you’re still in X, just run:

xrdb -merge ~/.Xdefaults

– Thomas Adam